diff mbox series

[bug#51300,1/2] gnu: waypipe: Simplify 'fix-sleep-path phase.

Message ID 20211020021936.1629519-1-contact@robbyzambito.me
State Accepted
Headers show
Series [bug#51300,1/2] gnu: waypipe: Simplify 'fix-sleep-path phase. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Robby Zambito Oct. 20, 2021, 2:19 a.m. UTC
* gnu/packages/freedesktop.scm (waypipe)
[arguments]: Remove inputs argument.
[native-inputs]: Remove coreutils.
---
 gnu/packages/freedesktop.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

Comments

Ludovic Courtès Oct. 28, 2021, 6:47 p.m. UTC | #1
Hi,

Robby Zambito <contact@robbyzambito.me> skribis:

> * gnu/packages/freedesktop.scm (waypipe)
> [arguments]: Remove inputs argument.
> [native-inputs]: Remove coreutils.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 086707d51a..eb19552746 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2454,16 +2454,14 @@  compositors.")
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-sleep-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((coreutils (assoc-ref inputs "coreutils")))
-               (substitute* "./test/startup_failure.py"
-                 (("sleep") (string-append coreutils "/bin/sleep")))))))))
+           (lambda* (#:key #:allow-other-keys)
+             (substitute* "./test/startup_failure.py"
+               (("sleep") (which "sleep"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("scdoc" ,scdoc)
        ;; For tests
-       ("python" ,python)
-       ("coreutils" ,coreutils)))
+       ("python" ,python)))
     (home-page "https://gitlab.freedesktop.org/mstoeckl/waypipe")
     (synopsis "Proxy for Wayland protocol applications")
     (description