diff mbox series

[bug#51280,2/5] gnu: openttd-opengfx: Update to 7.1.

Message ID 20211019070201.4635-2-felgru@posteo.net
State Accepted
Headers show
Series Update openttd to 12.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Oct. 19, 2021, 7:01 a.m. UTC
* packages/games.scm (openttd-opengfx): Update to 7.1.
  [arguments]: Use cc-for-target.
---
 gnu/packages/games.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index adf8dec02a..7afcbe860f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4324,7 +4324,7 @@  engine.  When you start it you will be prompted to download a graphics set.")
 (define openttd-opengfx
   (package
     (name "openttd-opengfx")
-    (version "0.6.1")
+    (version "7.1")
     (source
      (origin
        (method url-fetch)
@@ -4332,10 +4332,10 @@  engine.  When you start it you will be prompted to download a graphics set.")
                            version "/opengfx-" version "-source.tar.xz"))
        (sha256
         (base32
-         "0jgy8xv7r72m127qn09vr3rxhnbakl2990f7lldsk0d5d8n993vd"))))
+         "0nhzlk6s73qvznm5fdwcs1b42g2plf26s5ag39fvck45zm7m48jk"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:make-flags (list "CC=gcc"
+     `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
                           (string-append "INSTALL_DIR="
                                          (assoc-ref %outputs "out")
                                          "/share/games/openttd/baseset/opengfx"))