diff mbox series

[bug#51272,2/4] gnu: Add python-dbus-next.

Message ID 20211018174833.90312-2-singpolyma@singpolyma.net
State Accepted
Headers show
Series [bug#51272,1/4] gnu: python-xcffib: Upgrade to 0.11.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Oct. 18, 2021, 5:48 p.m. UTC
* gnu/packages/python-xyz.scm (python-debus-next): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6db446efac..4135812f11 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8839,6 +8839,31 @@  implementation of D-Bus.")
                               (package-inputs python-dbus)
                               equal?)))))
 
+(define-public python-dbus-next
+  (package
+    (name "python-dbus-next")
+    (version "0.2.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/altdesktop/python-dbus-next")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1ahaz52kny1p9xxv6phvk4iq56rg8li390wywlxf2yslaij1188h"))))
+    (build-system python-build-system)
+    (native-inputs
+      `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/altdesktop/python-dbus-next")
+    (synopsis "Zero-dependency DBus library for Python with asyncio support")
+    (description
+      "Python library for DBus that aims to be a fully featured high level
+library primarily geared towards integration of applications into desktop and
+mobile environments.")
+    (license license:expat)))
+
 (define-public python-notify2
   (package
     (name "python-notify2")