diff mbox series

[bug#51269] gnu: Add stcgal.

Message ID 20211018171654.3310-1-simon@simonsouth.net
State Accepted
Headers show
Series [bug#51269] gnu: Add stcgal. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Oct. 18, 2021, 5:16 p.m. UTC
* gnu/packages/embedded.scm (stcgal): New variable.
---
Tested on AArch64 and x86-64 with an STC89C52RC demo board and everything
appears to work fine.

Note I have (retroactively) added a copyright line for myself to reflect the
changes I've made to this file in the past year.

 gnu/packages/embedded.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: 878744c5e3be6165633ead99c0efdca88abfcaea

Comments

Ludovic Courtès Nov. 23, 2021, 8:25 a.m. UTC | #1
Hi,

Simon South <simon@simonsouth.net> skribis:

> * gnu/packages/embedded.scm (stcgal): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f388c11c3d..4315cc0618 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2020, 2021 Simon South <simon@simonsouth.net>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -1350,6 +1351,38 @@  (define-public fc-host-tools
     (home-page "https://www.freecalypso.org/")
     (license license:public-domain)))
 
+(define-public stcgal
+  (package
+    (name "stcgal")
+    (version "1.6")
+    (source (origin
+              ;; Neither the unit tests nor the "doc" subdirectory referred to
+              ;; by stcgal's setup.py is present in the source distribution on
+              ;; PyPI, so we fetch directly from the project's git repository
+              ;; instead.
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/grigorig/stcgal")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1d10qxyghz66zp7iqpm8q8rfv9jz9n609gxmfcav1lssmf1dlyk3"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pyserial" ,python-pyserial)
+       ("python-pyusb" ,python-pyusb)
+       ("python-tqdm" ,python-tqdm)))
+    (native-inputs
+     ;; For tests.
+     `(("python-pyyaml" ,python-pyyaml)))
+    (home-page "https://github.com/grigorig/stcgal")
+    (synopsis "Programmer for STC 8051-compatible microcontrollers")
+    (description "stcgal is a command-line flash-programming tool for STC
+MCU's line of Intel 8051-compatible microcontrollers, including those in the
+STC89, STC90, STC10, STC11, STC12, STC15 and STC8 series.")
+    (license license:expat)))
+
 (define-public stlink
   (package
     (name "stlink")