diff mbox series

[bug#50862,core-updates-frozen,07/19] gnu: Add layer-shell-qt.

Message ID 20211015093015.5834-8-mail@brendan.scot
State Accepted
Headers show
Series | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley Oct. 15, 2021, 9:30 a.m. UTC
* gnu/packages/kde-plasma.scm (layer-shell-qt): New variable.
---
 gnu/packages/kde-plasma.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 96e7ec6907..eb463a498a 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -136,6 +137,33 @@  directly, you need to tell @code{ssh-add} about it.  @code{ssh-add} will then
 call it if it is not associated to a terminal.")
     (license license:gpl2+)))
 
+(define-public layer-shell-qt
+  (package
+    (name "layer-shell-qt")
+    (version "5.22.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/" version
+                                  "/layer-shell-qt-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0i9gsckqk9608drxvym6ghcwxqilcf6ilcxq48sbrnpswid71k7z"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxkbcommon" ,libxkbcommon)
+       ("qtbase" ,qtbase-5)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtwayland" ,qtwayland)
+       ("wayland" ,wayland)
+       ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://invent.kde.org/plasma/layer-shell-qt")
+    (synopsis "Qt component for the Wayland ql-layer-shell protocol")
+    (description "Qt component for the Wayland ql-layer-shell protocol.")
+    (license license:gpl2+)))
+
 (define-public kscreenlocker
   (package
     (name "kscreenlocker")