diff mbox series

[bug#50862,core-updates-frozen,02/19] gnu: libdbusmenu-qt: Move (gnu packages qt).

Message ID 20211015093015.5834-3-mail@brendan.scot
State Accepted
Headers show
Series | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley Oct. 15, 2021, 9:29 a.m. UTC
*  gnu/packages/lxqt.scm: Delete libdbusmenu-qt.
*  gnu/packages/qt.scm: Readd libdbusmenu-qt.
This prevent amysterious module resolution issue when
attempting to use libdbusmenu in KDE modules.
---
 gnu/packages/lxqt.scm | 32 +-------------------------------
 gnu/packages/qt.scm   | 30 ++++++++++++++++++++++++++++++
 2 files changed, 31 insertions(+), 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 391d83b7c4..4230775dd0 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -68,36 +68,6 @@ 
 
 ;; Third party libraries
 
-(define-public libdbusmenu-qt
-  (package
-    (name "libdbusmenu-qt")
-    (version "0.9.3+16.04.20160218-0ubuntu1")
-    (source
-     (origin
-       (method git-fetch)
-       ;; Download from github rather than launchpad because launchpad trunk
-       ;; tarball hash is not deterministic.
-       (uri (git-reference
-             (url "https://github.com/unity8-team/libdbusmenu-qt")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0b7ii1cvmpcyl79gqal9c3va9m55h055s4hx7fpxkhhqs9463ggg"))))
-    (build-system cmake-build-system)
-    (arguments
-     ;; XXX: Tests require a dbus session and some icons.
-     '(#:tests? #f))
-    (native-inputs
-     `(("doxygen" ,doxygen)))
-    (inputs
-     `(("qtbase" ,qtbase-5)))
-    (home-page "https://launchpad.net/libdbusmenu-qt")
-    (synopsis "Qt implementation of the DBusMenu spec")
-    (description "This library provides a Qt implementation of the DBusMenu
-protocol.  The DBusMenu protocol makes it possible for applications to export
-and import their menus over DBus.")
-    (license license:lgpl2.1+)))
-
 (define-public libstatgrab
   (package
     (name "libstatgrab")
@@ -1425,7 +1395,7 @@  desktop.")
        ("lximage-qt" ,lximage-qt)
        ("obconf-qt" ,obconf-qt)
        ("openbox" ,openbox)
-       ("oxygen-icons" ,oxygen-icons)
+       ("breeze-icons" ,breeze-icons)
        ("pavucontrol-qt" ,pavucontrol-qt)
        ("qps" ,qps)
        ("qterminal" ,qterminal)))
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5ce4220cb0..962fb5a252 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3101,3 +3101,33 @@  being fully customizable and easy to extend.")
 also compatible with SGI and TGS Open Inventor, and the API is based on the API
 of the InventorXt GUI component toolkit.")
     (license license:bsd-3))))
+
+(define-public libdbusmenu-qt
+  (package
+    (name "libdbusmenu-qt")
+    (version "0.9.3+16.04.20160218-0ubuntu1")
+    (source
+     (origin
+       (method git-fetch)
+       ;; Download from github rather than launchpad because launchpad trunk
+       ;; tarball hash is not deterministic.
+       (uri (git-reference
+             (url "https://github.com/unity8-team/libdbusmenu-qt")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b7ii1cvmpcyl79gqal9c3va9m55h055s4hx7fpxkhhqs9463ggg"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; XXX: Tests require a dbus session and some icons.
+     '(#:tests? #f))
+    (native-inputs
+     `(("doxygen" ,doxygen)))
+    (inputs
+     `(("qtbase" ,qtbase-5)))
+    (home-page "https://launchpad.net/libdbusmenu-qt")
+    (synopsis "Qt implementation of the DBusMenu spec")
+    (description "This library provides a Qt implementation of the DBusMenu
+protocol.  The DBusMenu protocol makes it possible for applications to export
+and import their menus over DBus.")
+    (license license:lgpl2.1+)))