diff mbox series

[bug#51222,20/25] gnu: Add python-olm.

Message ID 20211015024036.53831-20-sl@eauchat.org
State Accepted
Headers show
Series Package python-pantalaimon | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sébastien Lerique Oct. 15, 2021, 2:40 a.m. UTC
* gnu/packages/python-xyz.scm (python-olm): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b5c40692db..f090eb2b5a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -229,6 +229,31 @@ 
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26))
 
+(define-public python-olm
+  (package
+    (name "python-olm")
+    (version "3.1.3")
+    (source
+     ;; Note: at the time of writing, the upstream version is 3.2.6, so it
+     ;; may be worth using the subfolder of the upstream git repository
+     ;; instead of PyPi.
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-olm" version))
+       (sha256
+        (base32 "0wg8zr1gbba8396pf3hsxmv2ysmkql9qpwg3i267hxrprqrn2v4s"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cffi" ,python-cffi)
+       ("python-future" ,python-future)))
+    (inputs
+     `(("libolm" ,libolm)))
+    (home-page "https://gitlab.matrix.org/matrix-org/olm")
+    (synopsis "Python CFFI bindings for the olm cryptographic ratchet library")
+    (description
+     "Python CFFI bindings for the olm cryptographic ratchet library.")
+    (license license:asl2.0)))
+
 (define-public python-aioresponses
   (package
     (name "python-aioresponses")