diff mbox series

[bug#51187] gnu: Add herbe.

Message ID 20211013184342.5930-1-ahmed@ikasero.com
State New
Headers show
Series [bug#51187] gnu: Add herbe. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

iKaSeRo Oct. 13, 2021, 6:43 p.m. UTC
* gnu/packages/suckless.scm (herbe): New variable.
---
 gnu/packages/suckless.scm | 40 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Ludovic Courtès Oct. 28, 2021, 7:12 p.m. UTC | #1
Hi,

iKaSeRo <ahmed@ikasero.com> skribis:

> * gnu/packages/suckless.scm (herbe): New variable.

Overall LGTM.  Minor comments:

> diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
> index b24eced379..f3ed9f1df6 100644
> --- a/gnu/packages/suckless.scm

Could you move it to, say, xdisorg.scm as it’s not related to
suckless.org?

> +    (home-page "https://github.com/dudik/herbe")
> +    (synopsis "Daemon-less notifications")
> +    (description "Daemon-less notifications without D-Bus.
> +You can use @code{tiramisu} to call @code{herbe}")

Please make full sentences and expound a tiny bit, as per
<https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.

TIA!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index b24eced379..f3ed9f1df6 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -303,6 +303,46 @@  optimising the environment for the application in use and the task performed.")
 numbers of user-defined menu items efficiently.")
     (license license:x11)))
 
+(define-public herbe
+  (package
+    (name "herbe")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dudik/herbe")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0358i5jmmlsvy2j85ij7m1k4ar2jr5lsv7y1c58dlf9710h186cv"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             (substitute* "Makefile"
+               (("CC \\?= cc")
+                (string-append "CC ="
+                               ,(cc-for-target)))
+               (("PREFIX \\?= /usr/local")
+                (string-append "PREFIX ="
+                               (assoc-ref outputs "out")))
+               (("/usr/include/freetype2")
+                (string-append (assoc-ref inputs "freetype")
+                               "/include/freetype2"))))))))
+    (inputs
+     `(("libx11" ,libx11)
+       ("libxft" ,libxft)))
+    (home-page "https://github.com/dudik/herbe")
+    (synopsis "Daemon-less notifications")
+    (description "Daemon-less notifications without D-Bus.
+You can use @code{tiramisu} to call @code{herbe}")
+    (license license:expat)))
+
 (define-public spoon
   (package
     (name "spoon")