diff mbox series

[bug#51174] gnu: Add python-giturlparse.

Message ID 20211013043636.11342-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51174] gnu: Add python-giturlparse. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 13, 2021, 4:36 a.m. UTC
* gnu/packages/python-web.scm (python-giturlparse): New variable.
---
 gnu/packages/python-web.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Efraim Flashner Nov. 8, 2021, 8:51 a.m. UTC | #1
I changed the description to make it more general and pushed the patch.
Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b99e358e26..9e5697b050 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6030,6 +6030,24 @@  over IMAP:
 @end itemize")
     (license license:asl2.0)))
 
+(define-public python-giturlparse
+  (package
+    (name "python-giturlparse")
+    (version "0.10.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "giturlparse" version))
+        (sha256
+          (base32 "0dxk7sqy8ibaqdl6jzxd0ac1p7shzp4p9f3lhkd7qw9h3llsp595"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/nephila/giturlparse")
+    (synopsis "Git URL parsing module")
+    (description 
+"Parse git URLs for GitHub, Bitbucket, FriendCode, Assembla, Gitlab, and
+more.")
+    (license license:asl2.0)))
+
 (define-public python-hstspreload
   (package
     (name "python-hstspreload")