diff mbox series

[bug#51169] gnu: Add r-pnwcolors.

Message ID 20211012204650.3150854-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#51169] gnu: Add r-pnwcolors. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Oct. 12, 2021, 8:46 p.m. UTC
* gnu/packages/cran.scm (r-pnwcolors): New variable.
---
 gnu/packages/cran.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)


base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0

Comments

Ricardo Wurmus Oct. 20, 2021, 8:58 a.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> * gnu/packages/cran.scm (r-pnwcolors): New variable.

Pushed it to the “master” branch.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 937f53784e..15f8df7cee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31,7 +31,7 @@ 
 ;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
-;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
 ;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
 ;;;
@@ -905,6 +905,28 @@  functions which can speed up workflow.")
 control over dimensions and appearance.")
     (license license:gpl2+)))
 
+(define-public r-pnwcolors
+  (package
+    (name "r-pnwcolors")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "PNWColors" version))
+       (sha256
+        (base32
+         "1phplnclkficfv8s6wsyrckk4ixzbayiy5iix6dddg40485l9nyj"))))
+    (properties `((upstream-name . "PNWColors")))
+    (build-system r-build-system)
+    (home-page
+     "https://github.com/jakelawlor/PNWColors")
+    (synopsis "Colors palettes for data visualizations")
+    (description
+     "This package provides color palettes.  They are checked for colorblind
+accessibility from hue, saturation, and lightness value scaling using the
+Chroma.js Color Palette Helper.  See <https://gka.github.io/palettes>.")
+    (license license:cc0)))
+
 (define-public r-ecp
   (package
     (name "r-ecp")