diff mbox series

[bug#51150,2/2] gnu: Remove python2-faker.

Message ID 20211012064830.23674-2-jgart@dismail.de
State Accepted
Headers show
Series [bug#51149,1/2] gnu: python-faker: Update to 9.3.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 12, 2021, 6:48 a.m. UTC
* gnu/packages/python-xyz.scm (python2-faker): Remove variable.
---
 gnu/packages/python-xyz.scm | 21 ---------------------
 1 file changed, 21 deletions(-)

Comments

Guillaume Le Vaillant Oct. 18, 2021, 9:52 a.m. UTC | #1
Currently python2-faker can't be removed because python2-factory-boy
depends on it. However it looks like nothing depends on
python2-factory-boy, so if nobody wants to keep it, you could add
a patch to remove it too.
jgart Oct. 19, 2021, 9:57 p.m. UTC | #2
On Mon, 18 Oct 2021 09:52:24 +0000 Guillaume Le Vaillant <glv@posteo.net> wrote:
> Currently python2-faker can't be removed because python2-factory-boy
> depends on it. However it looks like nothing depends on
> python2-factory-boy, so if nobody wants to keep it, you could add
> a patch to remove it too.

Ok, no worries.

Thanks for letting me know.

Glad the upgrade got merged.

all best,

jgart

3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 77B6 DD35
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61ac147ec7..a1ecfb0e03 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15699,27 +15699,6 @@  parsing UK postcodes.")
   (description
    "Faker is a Python package that generates fake data such as names,
 addresses, and phone numbers.")
-
-;; Faker 4.0 dropped Python 2 support, so we stick with this older version here.
-(define-public python2-faker
-  (let ((base (package-with-python2 (strip-python2-variant
-                                     python-faker))))
-    (package
-      (inherit base)
-      (version "3.0.1")
-      (source (origin
-                (method url-fetch)
-                (uri (pypi-uri "Faker" version))
-                (sha256
-                 (base32
-                  "11cr0qvspkdh6198rqy56qildk7bnp6llj8kyy1dan5sp5n4dxy7"))))
-      (native-inputs
-       `(("python-mock" ,python2-mock)
-         ,@(package-native-inputs base)))
-      (propagated-inputs
-       `(("python2-ipaddress" ,python2-ipaddress)
-         ("python2-six" ,python2-six)
-         ,@(package-propagated-inputs base))))))
   (license license:expat)))
 
 (define-public python-pyaml