diff mbox series

[bug#51149,1/2] gnu: python-faker: Update to 9.3.1.

Message ID 20211012064830.23674-1-jgart@dismail.de
State New
Headers show
Series [bug#51149,1/2] gnu: python-faker: Update to 9.3.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 12, 2021, 6:48 a.m. UTC
* gnu/packages/python-xyz.scm (python-faker): Update to 9.3.1.
[properties]: Remove python2-faker.
---
 gnu/packages/python-xyz.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Guillaume Le Vaillant Oct. 18, 2021, 9:48 a.m. UTC | #1
python-faker as been updated to 9.3.1 in commit
74a97b087b7d5b799bffd8b1fca826e5eabbe963 (issue #51222).
Closing.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 577bea8144..61ac147ec7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15671,13 +15671,13 @@  parsing UK postcodes.")
 (define-public python-faker
   (package
   (name "python-faker")
-  (version "4.0.2")
+  (version "9.3.1")
   (source (origin
             (method url-fetch)
             (uri (pypi-uri "Faker" version))
             (sha256
              (base32
-              "13qq485ydxmdnqn3xbfv1xfyqbf9qfnfw33v1vw5l6jyy9p8cgrd"))))
+              "0lpfdc4ndvk7chgqrfd2b1my4n54pccq9b645vp9cp5s5ypyknfd"))))
   (build-system python-build-system)
   (arguments
    '(#:phases
@@ -15699,8 +15699,6 @@  parsing UK postcodes.")
   (description
    "Faker is a Python package that generates fake data such as names,
 addresses, and phone numbers.")
-  (license license:expat)
-  (properties `((python2-variant . ,(delay python2-faker))))))
 
 ;; Faker 4.0 dropped Python 2 support, so we stick with this older version here.
 (define-public python2-faker
@@ -15722,6 +15720,7 @@  addresses, and phone numbers.")
        `(("python2-ipaddress" ,python2-ipaddress)
          ("python2-six" ,python2-six)
          ,@(package-propagated-inputs base))))))
+  (license license:expat)))
 
 (define-public python-pyaml
   (package