diff mbox series

[bug#50813,v2,5/6] gnu: synapse: Update to 1.44.0.

Message ID 20211010150434.1966-6-felgru@posteo.net
State New
Headers show
Series gnu: python-pandas: Update to 1.3.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Oct. 10, 2021, 3:04 p.m. UTC
* gnu/packages/matrix.scm (synapse): Update to 1.44.0.
---
 gnu/packages/matrix.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Michael Rohleder Oct. 13, 2021, 12:01 p.m. UTC | #1
Hello Felix,

Thank you for the patch!

Did you try running this version?

I think, synapse > 1.30 needs a newer python-cryptography (I think >=3.4) at
runtime, which we dont have currently...
(See also bug #48655)
Felix Gruber Oct. 13, 2021, 4:33 p.m. UTC | #2
Hi Michael,

On 10/13/21 2:01 PM, Michael Rohleder wrote:
> Thank you for the patch!
> 
> Did you try running this version?
> 
> I think, synapse > 1.30 needs a newer python-cryptography (I think >=3.4) at
> runtime, which we dont have currently...
> (See also bug #48655)

I didn't try to run synapse after the update. Sorry if I broke it. :-(
Michael Rohleder Oct. 14, 2021, 4:25 a.m. UTC | #3
Hi Felix,

Felix Gruber <felgru@posteo.net> writes:
> On 10/13/21 2:01 PM, Michael Rohleder wrote:
>> Thank you for the patch!
>> 
>> Did you try running this version?
>> 
>> I think, synapse > 1.30 needs a newer python-cryptography (I think >=3.4) at
>> runtime, which we dont have currently...
>> (See also bug #48655)
>
> I didn't try to run synapse after the update. Sorry if I broke it. :-(

Maybe it's possible to revert this patch?!

I think, a non working synapse is useless, no?
Felix Gruber Oct. 14, 2021, 7:08 p.m. UTC | #4
Hi Michael,

On 10/14/21 6:25 AM, Michael Rohleder wrote:
> Maybe it's possible to revert this patch?!
> 
> I think, a non working synapse is useless, no?

I've opened bug #51211 to revert my update of synapse.
diff mbox series

Patch

diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 5c2b194d07..e6b0b99630 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -86,13 +87,13 @@  an LDAP server.")
 (define-public synapse
   (package
     (name "synapse")
-    (version "1.29.0")
+    (version "1.44.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "matrix-synapse" version))
               (sha256
                (base32
-                "0if2yhpz8psg0661401mvxznldbfhk2j9rhbs25jdaqm9jsv6907"))))
+                "1lgi1a4ksz4z78yb84bi29x4y080bx1dadib2wznvmwsfif0azx0"))))
     (build-system python-build-system)
     ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
     (propagated-inputs