diff mbox series

[bug#49469] gnu: Add python-pysox.

Message ID 20211010061525.11302-2-jgart@dismail.de
State Accepted
Headers show
Series [bug#49469] gnu: Add python-pysox. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 10, 2021, 6:15 a.m. UTC
* gnu/packages/audio.scm (python-pysox): New variable.
---
 gnu/packages/audio.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)

Comments

Arun Isaac Oct. 16, 2021, 10:02 a.m. UTC | #1
Hi jgart,

Thanks for the updated patch! Some feedback follows.

> +(define-public python-pysox
> +  (let ((commit "3d0053381c24ae3490f759d4de87194b85789d36")
> +        (revision "0"))
> +    (package
> +      (name "python-pysox")
> +      (version (git-version "1.4.2" revision commit))

According to PyPI, it seems that the latest version is 1.4.1.

And, I see that upstream is not tagging releases correctly in their git
repo. Could you raise this issue with upstream?

> +      (source
> +        (origin
> +          (method git-fetch)
> +          (uri (git-reference
> +                 (url "https://github.com/rabitt/pysox")

We should prefer the PyPI source tarball. If there is something missing
in the PyPI source tarball, and that's why you are using the GitHub
source, could you add a comment explaining the reason?

> +                  (substitute* "sox/log.py"
> +                    (("Logger\\('sox")
> +                     (string-append "Logger\('" sox-bin))))))

I think the above substitution is not required, because in this instance
'sox' is the name of the logger, rather than the full path to the sox
executable.

> +                  (setenv "PYTHONPATH" (string-append ".:" (getenv
> "PYTHONPATH")))

This setting of PYTHONPATH does not seem to be required. The tests
succeed without it.

> +      (description
> +"@code{pysox} is a wrapper around the @command{sox} command line tool.
> + pysox's API offers @code{Transformer} and @code{Combiner} classes that allow the user to
> +incrementally build up effects and audio manipulations.  @code{pysox} also
> +provides methods for querying audio information such as sample rate,
> +determining whether an audio file is silent and much more.")

I think @code{pysox} should be @code{python-pysox} since we are
referring to the python-pysox scheme variable.

Could you send an updated patch? Also, please do use `git format-patch
-v2', `git format-patch -v3', etc. when sending updated patches.

Thanks!
Arun
Arun Isaac Oct. 16, 2021, 10:05 a.m. UTC | #2
Also, in the next patch, please add a copyright header for yourself.

Thanks!
Arun Isaac Nov. 24, 2021, 4:25 p.m. UTC | #3
Hi jgart,

Just a gentle reminder. I was wondering if you missed my last mail on
this patch.

Thanks,
Arun
jgart Nov. 25, 2021, 4:33 a.m. UTC | #4
On Wed, 24 Nov 2021 21:55:02 +0530 Arun Isaac <arunisaac@systemreboot.net> wrote:
> 
> Hi jgart,
> 
> Just a gentle reminder. I was wondering if you missed my last mail on
> this patch.
> 
> Thanks,
> Arun

Hi Arun,

Thank you for taking the time to review these patches.

Oddly enough, PyPi does not include the data folder that contains the audio files required for testing:

https://github.com/rabitt/pysox/tree/master/tests/data

Here is a snippet of the log showing test failures from not finding the data folder with the audio files:

/gnu/store/grnpyl2q67cyymcx7p27h5l64i23i4bn-python-pysox-1.4.1/lib/python3.8/site-packages/sox/file_info.py:248: OSError
________________ TestTransformerVol.test_limiter_gain_vol_up_db ________________

self = <test_transform.TestTransformerVol testMethod=test_limiter_gain_vol_up_db>

    def test_limiter_gain_vol_up_db(self):
        tfm = new_transformer()
        tfm.vol(2.0, gain_type='db', limiter_gain=0.05)

        actual_args = tfm.effects
        expected_args = ['vol', '2.000000', 'dB', '0.050000']
        self.assertEqual(expected_args, actual_args)

        actual_log = tfm.effects_log
        expected_log = ['vol']
        self.assertEqual(expected_log, actual_log)

>       actual_res = tfm.build(INPUT_FILE, OUTPUT_FILE)

tests/test_transform.py:5322:
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
/gnu/store/grnpyl2q67cyymcx7p27h5l64i23i4bn-python-pysox-1.4.1/lib/python3.8/site-packages/sox/transform.py:593: in build
    input_format, input_filepath = self._parse_inputs(
/gnu/store/grnpyl2q67cyymcx7p27h5l64i23i4bn-python-pysox-1.4.1/lib/python3.8/site-packages/sox/transform.py:493: in _parse_inputs
    file_info.validate_input_file(input_filepath)
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

input_filepath = '/tmp/guix-build-python-pysox-1.4.1.drv-0/sox-1.4.1/tests/data/input.wav'

    def validate_input_file(input_filepath):
        '''Input file validation function. Checks that file exists and can be
        processed by SoX.

        Parameters
        ----------
        input_filepath : str
            The input filepath.

        '''
        if not os.path.exists(input_filepath):
>           raise IOError(
                "input_filepath {} does not exist.".format(input_filepath)
            )
E           OSError: input_filepath /tmp/guix-build-python-pysox-1.4.1.drv-0/sox-1.4.1/tests/data/input.wav does not exist.

/gnu/store/grnpyl2q67cyymcx7p27h5l64i23i4bn-python-pysox-1.4.1/lib/python3.8/site-packages/sox/file_info.py:248: OSError
================= 282 failed, 373 passed, 10 skipped in 51.02s =================


Next email will contain the new patch set with your suggestions. I've included a copyright statement also.

Thank you!

all best,

jgart
jgart Nov. 25, 2021, 4:46 a.m. UTC | #5
On Wed, 24 Nov 2021 23:33:28 -0500 jgart <jgart@dismail.de> wrote:

I sent the latest patch set (v3) but forgot to Cc you ;)

all best,

jgart
Arun Isaac Nov. 29, 2021, 4:12 p.m. UTC | #6
Hi jgart,

Thank you for your revised patch! I have pushed it to master.

> Oddly enough, PyPi does not include the data folder that contains the
> audio files required for testing:

Personally, I believe this is bad practice, but sadly it is quite
common.

Regards,
Arun
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index cc51ac51f3..8b412a63d1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2429,6 +2429,63 @@  compensation, (de)interleaving, and byte-swapping
     ;; original developer.
     (license license:expat)))
 
+(define-public python-pysox
+  (let ((commit "3d0053381c24ae3490f759d4de87194b85789d36")
+        (revision "0"))
+    (package
+      (name "python-pysox")
+      (version (git-version "1.4.2" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/rabitt/pysox")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+            (base32
+              "0i62jx92vfpcr2z7lp69yzqdi9idfs3pifl3rzm2akc2c4cr1mac"))))
+      (build-system python-build-system)
+      (arguments
+        `(#:phases
+          (modify-phases %standard-phases
+            (add-after 'unpack 'patch-sox
+              (lambda* (#:key inputs #:allow-other-keys)
+                (let* ((sox-store-path (assoc-ref inputs "sox"))
+                       (sox-bin (string-append sox-store-path "/bin/sox")))
+                  (substitute* "sox/__init__.py"
+                    (("sox -h")
+                     (string-append sox-bin " -h")))
+                  (substitute* "sox/core.py"
+                    (("\\['sox")
+                     (string-append "['" sox-bin)))
+                  (substitute* "sox/log.py"
+                    (("Logger\\('sox")
+                     (string-append "Logger\('" sox-bin))))))
+            (replace 'check
+              (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+                (when tests?
+                  (add-installed-pythonpath inputs outputs)
+                  (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH")))
+                  (invoke "pytest")))))))
+      (propagated-inputs
+        `(("python-numpy" ,python-numpy)
+          ("python-typing-extensions" ,python-typing-extensions)))
+      (native-inputs
+        `(("sox" ,sox)
+          ("python-pytest" ,python-pytest)
+          ("python-pytest-cov" ,python-pytest-cov)
+          ("python-soundfile" ,python-soundfile)))
+      (home-page "https://github.com/rabitt/pysox")
+      (synopsis "Python wrapper around sox")
+      (description
+"@code{pysox} is a wrapper around the @command{sox} command line tool.
+ pysox's API offers @code{Transformer} and @code{Combiner} classes that allow the user to
+incrementally build up effects and audio manipulations.  @code{pysox} also
+provides methods for querying audio information such as sample rate,
+determining whether an audio file is silent and much more.")
+      (license license:bsd-3))))
+
 (define-public python-pyaudio
   (package
     (name "python-pyaudio")