diff mbox series

[bug#51106,4/7] gnu: gegl: Enable GIR.

Message ID 20211009010736.269383-4-monego@posteo.net
State Accepted
Headers show
Series Update GIMP to 2.10.28. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 9, 2021, 1:07 a.m. UTC
* gnu/packages/gimp.scm (gegl)[arguments]<#:configure-flags>: Pass
"-Dintrospection=true".
[native-inputs]: Add gobject-introspection, vala.
---
 gnu/packages/gimp.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler Oct. 9, 2021, 12:42 p.m. UTC | #1
Hi,

Am Samstag, den 09.10.2021, 01:07 +0000 schrieb Vinicius Monego:
> * gnu/packages/gimp.scm (gegl)[arguments]<#:configure-flags>: Pass
> "-Dintrospection=true".
> [native-inputs]: Add gobject-introspection, vala.
> ---
>  gnu/packages/gimp.scm | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
> index 37879cf5bf..fc4b882912 100644
> --- a/gnu/packages/gimp.scm
> +++ b/gnu/packages/gimp.scm
> @@ -231,7 +231,7 @@ provided, as well as a framework to add new color
> models and data types.")
>      (arguments
>       `(#:meson ,meson-0.55
>         #:configure-flags
> -       (list "-Dintrospection=false")
> +       (list "-Dintrospection=true")
As with babl, I don't think we ened to explicitly pass this.
>         #:phases
>         (modify-phases %standard-phases
>           (add-after 'unpack 'extend-test-time-outs
> @@ -259,7 +259,9 @@ provided, as well as a framework to add new color
> models and data types.")
>      (native-inputs
>       `(("pkg-config" ,pkg-config)
>         ("glib" ,glib "bin")             ; for gtester
> -       ("intltool" ,intltool)))
> +       ("gobject-introspection" ,gobject-introspection)
> +       ("intltool" ,intltool)
> +       ("vala" ,vala)))
It'd be good to sort these, no?
>      (home-page "https://gegl.org")
>      (synopsis "Graph based image processing framework")
>      (description "GEGL (Generic Graphics Library) provides
> infrastructure to
diff mbox series

Patch

diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 37879cf5bf..fc4b882912 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -231,7 +231,7 @@  provided, as well as a framework to add new color models and data types.")
     (arguments
      `(#:meson ,meson-0.55
        #:configure-flags
-       (list "-Dintrospection=false")
+       (list "-Dintrospection=true")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'extend-test-time-outs
@@ -259,7 +259,9 @@  provided, as well as a framework to add new color models and data types.")
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib "bin")             ; for gtester
-       ("intltool" ,intltool)))
+       ("gobject-introspection" ,gobject-introspection)
+       ("intltool" ,intltool)
+       ("vala" ,vala)))
     (home-page "https://gegl.org")
     (synopsis "Graph based image processing framework")
     (description "GEGL (Generic Graphics Library) provides infrastructure to