diff mbox series

[bug#51064] gnu: fish: Update to 3.3.1

Message ID 20211006181722.138-1-gnu@filipstaffa.net
State Accepted
Headers show
Series [bug#51064] gnu: fish: Update to 3.3.1 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Filip Staffa Oct. 6, 2021, 6:17 p.m. UTC
* gnu/packages/shells.scm (fish): Update to 3.3.1
---
 gnu/packages/shells.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.25.1

Comments

Ludovic Courtès Oct. 12, 2021, 3:02 p.m. UTC | #1
Hi Filip,

Filip Staffa <gnu@filipstaffa.net> skribis:

> * gnu/packages/shells.scm (fish): Update to 3.3.1

On x86_64-linux, I’m getting this test failure:

--8<---------------cut here---------------start------------->8---
Testing file checks/invocation.fish ... ok (56 ms)
Testing file checks/job-control-noninteractive.fish ... ok (14 ms)
Testing file checks/job-control-not-a-tty.fish ... ok (8 ms)
Testing file checks/job-ids.fish ... ok (13 ms)
Testing file checks/jobs.fish ... Failure:

  The CHECK on line 18 wants:
    All clear of zombies.

  which failed to match line stdout:1:
    Found existing zombie processes. Clean up zombies before running this test.

  Context:
    Found existing zombie processes. Clean up zombies before running this test. <= does not match CHECK 'All clear of zombies.' on line 18
     <= nothing to match CHECK 'Trigger process reaping' on line 28
     <= nothing to match CHECK '1' on line 46
     <= nothing to match CHECK 'Command' on line 50
     <= nothing to match CHECK 'sleep' on line 51
     <= nothing to match CHECK 'sleep' on line 52
     <= nothing to match CHECK '0' on line 55
     <= nothing to match CHECK 'Command' on line 66
     <= nothing to match CHECK 'sleep' on line 67
     <= nothing to match CHECK 'sleep' on line 68
     <= nothing to match CHECK '1' on line 71
     <= nothing to match CHECK '2' on line 75
     <= nothing to match CHECK '1' on line 79
     <= nothing to match CHECK '2' on line 82
     <= nothing to match CHECK 'Command' on line 110
     <= nothing to match CHECK 'sleep' on line 111
     <= nothing to match CHECK 'sleep is done' on line 112
     <= nothing to match CHECK '1' on line 113
     <= nothing to match CHECK 'Command' on line 117
     <= nothing to match CHECK 'sleep' on line 118
     <= nothing to match CHECK '0' on line 119
     <= nothing to match CHECK 'foo' on line 133
     <= nothing to match CHECK 'caller' on line 134

  when running command:
    ../test/root/bin/fish checks/jobs.fish
Testing file checks/line-continuation.fish ... ok (6 ms)
Testing file checks/line-number.fish ... ok (6 ms)
Testing file checks/locale.fish ... ok (28 ms)
--8<---------------cut here---------------end--------------->8---

Does that ring a bell?  Any suggestions?

Thanks,
Ludo’.
Filip Staffa Oct. 12, 2021, 7:31 p.m. UTC | #2
Hi Ludo’,

thanks for checking the patch. It worked on my machine, so I have checked the test itself. It looks like in your case it failed on a precondition. It checks the environment for processes matching Z*, and if it find any it fails.
Specifically this command (found here: https://github.com/fish-shell/fish-shell/blob/Integration_3.3.1/tests/checks/jobs.fish#L9 ):
ps -o s | string match 'Z*' | count

Would you be able to stop all such processes/run it in environment where this command returns 0? If not I would propose to close this patch and wait for next version of fish shell, it looks like they fixed the test to be less flaky on Fish master branch.

Regards,

Filip


‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Tuesday, October 12th, 2021 at 17:02, Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Filip,
>
> Filip Staffa gnu@filipstaffa.net skribis:
>
> > -   gnu/packages/shells.scm (fish): Update to 3.3.1
>
> On x86_64-linux, I’m getting this test failure:
>
> --8<---------------cut here---------------start------------->8---
>
> Testing file checks/invocation.fish ... ok (56 ms)
>
> Testing file checks/job-control-noninteractive.fish ... ok (14 ms)
>
> Testing file checks/job-control-not-a-tty.fish ... ok (8 ms)
>
> Testing file checks/job-ids.fish ... ok (13 ms)
>
> Testing file checks/jobs.fish ... Failure:
>
> The CHECK on line 18 wants:
>
> All clear of zombies.
>
> which failed to match line stdout:1:
>
> Found existing zombie processes. Clean up zombies before running this test.
>
> Context:
>
> Found existing zombie processes. Clean up zombies before running this test. <= does not match CHECK 'All clear of zombies.' on line 18
>
> <= nothing to match CHECK 'Trigger process reaping' on line 28
>
> <= nothing to match CHECK '1' on line 46
>
> <= nothing to match CHECK 'Command' on line 50
>
> <= nothing to match CHECK 'sleep' on line 51
>
> <= nothing to match CHECK 'sleep' on line 52
>
> <= nothing to match CHECK '0' on line 55
>
> <= nothing to match CHECK 'Command' on line 66
>
> <= nothing to match CHECK 'sleep' on line 67
>
> <= nothing to match CHECK 'sleep' on line 68
>
> <= nothing to match CHECK '1' on line 71
>
> <= nothing to match CHECK '2' on line 75
>
> <= nothing to match CHECK '1' on line 79
>
> <= nothing to match CHECK '2' on line 82
>
> <= nothing to match CHECK 'Command' on line 110
>
> <= nothing to match CHECK 'sleep' on line 111
>
> <= nothing to match CHECK 'sleep is done' on line 112
>
> <= nothing to match CHECK '1' on line 113
>
> <= nothing to match CHECK 'Command' on line 117
>
> <= nothing to match CHECK 'sleep' on line 118
>
> <= nothing to match CHECK '0' on line 119
>
> <= nothing to match CHECK 'foo' on line 133
>
> <= nothing to match CHECK 'caller' on line 134
>
> when running command:
>
> ../test/root/bin/fish checks/jobs.fish
>
> Testing file checks/line-continuation.fish ... ok (6 ms)
>
> Testing file checks/line-number.fish ... ok (6 ms)
>
> Testing file checks/locale.fish ... ok (28 ms)
>
> --8<---------------cut here---------------end--------------->8---
>
> Does that ring a bell? Any suggestions?
>
> Thanks,
>
> Ludo’.
Ludovic Courtès Oct. 15, 2021, 3:16 p.m. UTC | #3
Hi Filip,

Filip Staffa <gnu@filipstaffa.net> skribis:

> thanks for checking the patch. It worked on my machine, so I have
> checked the test itself. It looks like in your case it failed on a
> precondition. It checks the environment for processes matching Z*, and
> if it find any it fails.  Specifically this command (found here:
> https://github.com/fish-shell/fish-shell/blob/Integration_3.3.1/tests/checks/jobs.fish#L9
> ): ps -o s | string match 'Z*' | count

Builds happen in an isolated environment, specifically in a separate PID
namespace.  So what’s running on my machine shouldn’t matter.

> Would you be able to stop all such processes/run it in environment
> where this command returns 0? If not I would propose to close this
> patch and wait for next version of fish shell, it looks like they
> fixed the test to be less flaky on Fish master branch.

Alternatively, if you prefer, we can apply upstream’s patch in Guix.

Let me know!

Thanks,
Ludo’.
Filip Staffa Oct. 15, 2021, 3:42 p.m. UTC | #4
Hi Ludo’,

I am new to Guix and have no knowledge of Fish source code, so I am not sure how to replicate/debug the issue.
I propose to close this patch, and I will create a new one once new version of Fish gets released. If the issue persists with the new version, I will hopefully have more knowledge by then to debug it :-)

Regards,

Filip


‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Friday, October 15th, 2021 at 17:16, Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Filip,
>
> Filip Staffa gnu@filipstaffa.net skribis:
>
> > thanks for checking the patch. It worked on my machine, so I have
> >
> > checked the test itself. It looks like in your case it failed on a
> >
> > precondition. It checks the environment for processes matching Z*, and
> >
> > if it find any it fails. Specifically this command (found here:
> >
> > https://github.com/fish-shell/fish-shell/blob/Integration_3.3.1/tests/checks/jobs.fish#L9
> >
> > ): ps -o s | string match 'Z*' | count
>
> Builds happen in an isolated environment, specifically in a separate PID
>
> namespace. So what’s running on my machine shouldn’t matter.
>
> > Would you be able to stop all such processes/run it in environment
> >
> > where this command returns 0? If not I would propose to close this
> >
> > patch and wait for next version of fish shell, it looks like they
> >
> > fixed the test to be less flaky on Fish master branch.
>
> Alternatively, if you prefer, we can apply upstream’s patch in Guix.
>
> Let me know!
>
> Thanks,
>
> Ludo’.
Ludovic Courtès Oct. 15, 2021, 10:26 p.m. UTC | #5
Hi,

Filip Staffa <gnu@filipstaffa.net> skribis:

> I am new to Guix and have no knowledge of Fish source code, so I am not sure how to replicate/debug the issue.
> I propose to close this patch, and I will create a new one once new version of Fish gets released. If the issue persists with the new version, I will hopefully have more knowledge by then to debug it :-)

Alright, closing!  (By sending this message to
NNN-done@debbugs.gnu.org.)

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 62862516c3..4f2a63f3cf 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -113,7 +113,7 @@  direct descendant of NetBSD's Almquist Shell (@command{ash}).")
 (define-public fish
   (package
     (name "fish")
-    (version "3.2.2")
+    (version "3.3.1")
     (source
      (origin
        (method url-fetch)
@@ -121,7 +121,7 @@  direct descendant of NetBSD's Almquist Shell (@command{ash}).")
                            "releases/download/" version "/"
                            "fish-" version ".tar.xz"))
        (sha256
-        (base32 "02a0dgz5cy4iv3ysvl5kzzd4ji8pxqv93zd45041plcki0ddli2r"))
+        (base32 "12dfkyqv5vm52i1fifz91h8f8xg60xjvv94kx6xjqxk9a8dfxd5m"))
        (modules '((guix build utils)))
        (snippet
         '(begin