diff mbox series

[bug#50905,33/38] gnu: heimdal: Make some parts of phases unconditional.

Message ID 20210929221938.17168-33-maximedevos@telenet.be
State Accepted
Headers show
Series Clean up TODO(core-updates) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/issue success View issue
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Sept. 29, 2021, 10:19 p.m. UTC
* gnu/packages/kerberos.scm (heimdal)[arguments]<#:phases>{pre-configure}:
  Make the '(%current-target-system)' branches unconditional.
---
 gnu/packages/kerberos.scm | 36 ++++++++++++------------------------
 1 file changed, 12 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 82609ce66e..6bfb758900 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -237,14 +237,7 @@  After installation, the system administrator should generate keys using
                   #~()))
        #:phases (modify-phases %standard-phases
                   (add-before 'configure 'pre-configure
-                    ;; TODO(core-updates): Unconditionally use the
-                    ;; %current-target-system branch.
-                    (,(if (%current-target-system)
-                          'lambda*
-                          'lambda)
-                     ,(if (%current-target-system)
-                          '(#:key inputs #:allow-other-keys)
-                          '_)
+                    (lambda* (#:key inputs #:allow-other-keys)
                      ,@(if (%current-target-system)
                            `((substitute* "configure"
                                ;; The e2fsprogs input is included for libcom_err,
@@ -256,22 +249,17 @@  After installation, the system administrator should generate keys using
                                (("ac_cv_prog_COMPILE_ET=\\$\\{with_cross_tools\\}compile_et")
                                 "ac_cv_PROG_COMPILE_ET=compile_et")))
                            '())
-                     ,@(if (%current-target-system)
-                           '((substitute* '("appl/afsutil/pagsh.c" "appl/su/su.c")
-                               (("/bin/sh")
-                                (search-input-file inputs "bin/sh"))
-                               ;; Use the cross-compiled bash instead of the
-                               ;; native bash (XXX shouldn't _PATH_BSHELL point
-                               ;; to a cross-compiled bash?).
-                               (("_PATH_BSHELL")
-                                (string-append
-                                 "\"" (search-input-file inputs "bin/sh") "\"")))
-                             (substitute* '("tools/Makefile.in")
-                               (("/bin/sh") (which "sh"))))
-                           '((substitute* '("appl/afsutil/pagsh.c"
-                                            "tools/Makefile.in")
-                               (("/bin/sh") (which "sh")))
-                             #t))))
+                     (substitute* '("appl/afsutil/pagsh.c" "appl/su/su.c")
+                       (("/bin/sh")
+                        (search-input-file inputs "bin/sh"))
+                       ;; Use the cross-compiled bash instead of the
+                       ;; native bash (XXX shouldn't _PATH_BSHELL point
+                       ;; to a cross-compiled bash?).
+                       (("_PATH_BSHELL")
+                        (string-append
+                         "\"" (search-input-file inputs "bin/sh") "\"")))
+                     (substitute* '("tools/Makefile.in")
+                       (("/bin/sh") (which "sh")))))
                   (add-before 'check 'pre-check
                     (lambda _
                       ;; For 'getxxyyy-test'.