diff mbox series

[bug#50844] Update vim to v8.2.3455

Message ID 20210927083219.2256220-1-steve@futurile.net
State Accepted
Headers show
Series [bug#50844] Update vim to v8.2.3455 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Steve George Sept. 27, 2021, 8:32 a.m. UTC
---
 gnu/packages/vim.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Efraim Flashner Sept. 30, 2021, 9:19 a.m. UTC | #1
On Mon, Sep 27, 2021 at 09:32:19AM +0100, Steve George wrote:
> ---
>  gnu/packages/vim.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index 98e96b331f..4e06b988fb 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -73,7 +73,7 @@
>  (define-public vim
>    (package
>      (name "vim")
> -    (version "8.2.2689")
> +    (version "8.2.3455")
>      (source (origin
>               (method git-fetch)
>               (uri (git-reference
> @@ -82,7 +82,7 @@
>               (file-name (git-file-name name version))
>               (sha256
>                (base32
> -               "0l0hkr8cw7fdsfc5zzcxx3q1wmv9k3hrgalvffq0l69lviqdgh0p"))))
> +               "128j5zrvx45vr8qsf083idyhzx4c9rir5c5bfay1r0n80wf0f4nw"))))
>      (build-system gnu-build-system)
>      (arguments
>       `(#:test-target "test"
> -- 
> 2.17.1
> 

I'm definitely looking forward to an update to vim, but I got a test
failure while building it for x86_64, and then the same test when I
built vim-full. Did you see this test failure?

-------------------------------
Executed:  4369 Tests
 Skipped:   119 Tests
  FAILED:     1 Tests


Failures:
        From test_shell.vim:
        Found errors in Test_shellxquote():
        Caught exception in Test_shellxquote(): Vim(call):E484: Can't open file Xlog @ command line..script /tmp/guix-build-vim-8.2.3455.drv-0/source/src/testdir/runtest.vim[486]..function RunTheTest[44]..Test_shellxquote, line 13

TEST FAILURE
make[2]: *** [Makefile:49: report] Error 1
make[2]: Leaving directory '/tmp/guix-build-vim-8.2.3455.drv-0/source/src/testdir'
make[1]: *** [Makefile:2271: scripttests] Error 2
make[1]: Leaving directory '/tmp/guix-build-vim-8.2.3455.drv-0/source/src'
make: *** [Makefile:39: test] Error 2

Test suite failed, dumping logs.
Tobias Geerinckx-Rice Oct. 3, 2021, 3:56 p.m. UTC | #2
Steve,

I've also tried to build this new vim about 10 times now, never 
successfully.  In my experience spurious test failures aren't 
unusual for vim, but it's not usually this hard to get them to 
pass.

Did you manage to build and use this new version from the first 
try?

Kind regards,

T G-R
Steve George Oct. 5, 2021, 11:25 a.m. UTC | #3
Hi Tobias/Efraim,

Apologies for the delay, this is my first attempt at a contribution and 
I've been learning/struggling with my set-ups repeatability.

The Test_shellxquote (from test_shell.vim) test fails for me 
consistently after patch 3061.

I can get the current version in Guix to build fine:

   guix environment guix --pure
   ./pre-inst-env guix environment vim

   ./pre-inst-env guix build vim --no-substitutes --verbosity=3 
--keep-failed 2>&1 | tee ../8.2.2689-vim-build.log

In 3061 
(https://github.com/vim/vim/commit/054794c20f6322bbd9482c4124041dc0a140c78e) 
the shell tests were changed. This build fails for me:

./pre-inst-env guix build vim --no-substitutes --verbosity=3 
--with-git-url=vim=https://github.com/vim/vim 
--with-commit=vim=v8.2.3061 --keep-failed 2>&1 | tee 
../8.2.3061-git-vim-build.log

Failures:
         From test_shell.vim:
         Found errors in Test_shellxquote():
         Caught exception in Test_shellxquote(): Vim(call):E484: Can't 
open file Xlog @ command line..script 
/tmp/guix-build-vim-8.2.3477.drv-0/source/src/testdir/runtest.vim[486]..function 
RunTheTest[44]..Test_shellxquote, line 13

In the tests log it says:

Cannot execute shell ./Xtestshell

The issue appears to be that if the Xtestshell file is there already 
then it fails.

I can build it fine manually:

   guix environment guix --pure
   ./pre-inst-env guix environment vim --ad-hoc less
   cd <source location>
   source ./environment-variables
   cd src/testdir
   mv Xtestshell Xtestshell.bak
   make

That's as far as I've got at this point.

Are either of you able to confirm that you can:

a. Build versions before 3061 (ie 3060)

b. That with 3061 if you move Xtestshell it builds

c. Suggest any paths from here?


Thanks,

Steve


On 10/3/21 3:56 PM, Tobias Geerinckx-Rice wrote:
> Steve,
> 
> I've also tried to build this new vim about 10 times now, never
> successfully.  In my experience spurious test failures aren't unusual
> for vim, but it's not usually this hard to get them to pass.
> 
> Did you manage to build and use this new version from the first try?
> 
> Kind regards,
> 
> T G-R
Efraim Flashner Oct. 5, 2021, 12:33 p.m. UTC | #4
On Tue, Oct 05, 2021 at 12:25:34PM +0100, Steve George wrote:
> Hi Tobias/Efraim,
> 
> Apologies for the delay, this is my first attempt at a contribution and I've
> been learning/struggling with my set-ups repeatability.
> 
> The Test_shellxquote (from test_shell.vim) test fails for me consistently
> after patch 3061.
> 
> I can get the current version in Guix to build fine:
> 
>   guix environment guix --pure
>   ./pre-inst-env guix environment vim
> 
>   ./pre-inst-env guix build vim --no-substitutes --verbosity=3 --keep-failed
> 2>&1 | tee ../8.2.2689-vim-build.log
> 
> In 3061
> (https://github.com/vim/vim/commit/054794c20f6322bbd9482c4124041dc0a140c78e)
> the shell tests were changed. This build fails for me:
> 
> ./pre-inst-env guix build vim --no-substitutes --verbosity=3
> --with-git-url=vim=https://github.com/vim/vim --with-commit=vim=v8.2.3061
> --keep-failed 2>&1 | tee ../8.2.3061-git-vim-build.log
> 
> Failures:
>         From test_shell.vim:
>         Found errors in Test_shellxquote():
>         Caught exception in Test_shellxquote(): Vim(call):E484: Can't open
> file Xlog @ command line..script /tmp/guix-build-vim-8.2.3477.drv-0/source/src/testdir/runtest.vim[486]..function
> RunTheTest[44]..Test_shellxquote, line 13
> 
> In the tests log it says:
> 
> Cannot execute shell ./Xtestshell
> 
> The issue appears to be that if the Xtestshell file is there already then it
> fails.
> 
> I can build it fine manually:
> 
>   guix environment guix --pure
>   ./pre-inst-env guix environment vim --ad-hoc less
>   cd <source location>
>   source ./environment-variables
>   cd src/testdir
>   mv Xtestshell Xtestshell.bak
>   make
> 
> That's as far as I've got at this point.
> 
> Are either of you able to confirm that you can:
> 
> a. Build versions before 3061 (ie 3060)
> 
> b. That with 3061 if you move Xtestshell it builds
> 
> c. Suggest any paths from here?
> 
> 
> Thanks,
> 
> Steve
> 

./pre-inst-env guix build --no-grafts --no-substitutes vim --with-commit=vim=v8.2.3060
worked for me on the machines I was able to test it on.

(ins)efraim@3900XT ~$ cat /tmp/guix-build-vim-8.2.3061.drv-0/source/src/testdir/Xtestshell
#!/bin/sh
echo "Cmd: [$*]" > Xlog

After adding 'testdir/test_shell.vim' to the '/bin/sh' substitution in the
'patch-absolute-paths phase I was able to build 8.2.3061.

I'd go ahead and make that change in the substitution and if that fixes
the version you sent then either resend that patch with the change or
try bumping vim to a later version.
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 98e96b331f..4e06b988fb 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -73,7 +73,7 @@ 
 (define-public vim
   (package
     (name "vim")
-    (version "8.2.2689")
+    (version "8.2.3455")
     (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -82,7 +82,7 @@ 
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "0l0hkr8cw7fdsfc5zzcxx3q1wmv9k3hrgalvffq0l69lviqdgh0p"))))
+               "128j5zrvx45vr8qsf083idyhzx4c9rir5c5bfay1r0n80wf0f4nw"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"