diff mbox series

[bug#48364,2/7] gnu: Add go-github-com-charmbracelet-bubbletea.

Message ID 20210926084447.2779-2-jgart@dismail.de
State Accepted
Headers show
Series [bug#48364,1/7] gnu: go-golang-org-colorful: Update to 1.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Sept. 26, 2021, 8:44 a.m. UTC
From: Guix Together <jgart@dismail.de>

* gnu/packages/golang.scm (go-github-com-charmbracelet-bubbletea): New variable.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Gábor Boskovits <boskovits@gmail.com>
---
 gnu/packages/golang.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a5ce91bb56..0ab20238e8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3309,6 +3309,44 @@  middleware for Go web applications and services.")
     (description "Safe and easy casting from one type to another in Go")
     (license license:expat)))
 
+(define-public go-github-com-charmbracelet-bubbletea
+  (package
+    (name "go-github-com-charmbracelet-bubbletea")
+    (version "0.13.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/charmbracelet/bubbletea")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/charmbracelet/bubbletea"))
+    (propagated-inputs
+     `(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
+       ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
+       ("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
+       ("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
+       ("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
+       ("go-golang-org-colorful" ,go-golang-org-colorful)
+       ("github.com/containerd/console" ,go-github-com-containerd-console)
+       ("go-github-com-muesli-reflow-truncate" ,go-github-com-muesli-reflow-truncate)
+       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+       ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+       ("go-golang-org-x-term" ,go-golang-org-x-term)
+       ("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)))
+    (home-page "https://github.com/charmbracelet/bubbletea")
+    (synopsis "A powerful little TUI framework")
+    (description 
+"A Go framework based on The Elm Architecture. Bubble Tea is well-suited
+for simple and complex terminal applications, either inline, full-window,
+or a mix of both.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-spf13-cobra
   (package
     (name "go-github-com-spf13-cobra")