diff mbox series

[bug#50750] gnu: Add trezor-gpg-pinentry-tk 0.0.10.

Message ID 20210925160803.2679-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#50750] gnu: Add trezor-gpg-pinentry-tk 0.0.10. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai Sept. 25, 2021, 4:08 p.m. UTC
* gnu/packages/finance.scm (trezor-gpg-pinentry-tk): New variable.
---

Thank you for catching all these mistakes, especially the licence!

 gnu/packages/finance.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Xinglu Chen Sept. 26, 2021, 9:23 a.m. UTC | #1
On Sat, Sep 25 2021, Attila Lendvai wrote:

> * gnu/packages/finance.scm (trezor-gpg-pinentry-tk): New variable.
> ---
>
> Thank you for catching all these mistakes, especially the licence!

You are welcome!  The updated patch LGTM, but I don’t have commit
access, so someone else will have to merge it.
Efraim Flashner Oct. 4, 2021, 8:42 a.m. UTC | #2
Thanks. I made a few other small changes. I added #:tests? #f to
arguments, since there weren't any tests. I also moved python:tk to
inputs. Since it is a leaf package we can rely on the PYTHONPATH
wrapping of the binary to ensure it is available at runtime.

Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 4aaab58906..8347821af5 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -884,6 +884,31 @@  the Monero GUI client.")
 Ledger Nano as a hardware SSH/GPG agent.")
     (license license:lgpl3)))
 
+(define-public trezor-gpg-pinentry-tk
+  (package
+    (name "trezor-gpg-pinentry-tk")
+    (version "0.0.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rendaw/trezor-gpg-pinentry-tk/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mblx4favmw4nf7k9rfl00ivv77kgdiwghyz4xv5cp0v410kjaqc"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-tkinter" ,python "tk")))
+    (home-page "https://github.com/rendaw/trezor-gpg-pinentry-tk")
+    (synopsis "GPG pinentry program for use with @code{trezor-agent}")
+    (description
+     "This package provides a GPG pinentry program for use with
+@code{trezor-agent}, or for people with number-only PINs.  It displays
+a grid of unlabeled buttons and supports configurable keyboard
+settings.")
+    (license license:bsd-2)))
+
 (define-public python-mnemonic
   (package
     (name "python-mnemonic")