diff mbox series

[bug#50750,1/2] gnu: Add trezor-gpg-pinentry-tk 0.0.10.

Message ID 20210923080914.6149-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#50750,1/2] gnu: Add trezor-gpg-pinentry-tk 0.0.10. | expand

Commit Message

Attila Lendvai Sept. 23, 2021, 8:09 a.m. UTC
* gnu/packages/finance.scm (trezor-gpg-pinentry-tk): New variable.
---
 gnu/packages/finance.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Attila Lendvai Sept. 23, 2021, 8:27 a.m. UTC | #1
please ignore the 1of2 part. i meant to send only one patch, but i'm still learning git send-email.

i'll send the updating of Trezor support in a separate email.

- attila
PGP: 5D5F 45C7 DFCD 0A39
Xinglu Chen Sept. 24, 2021, 1:49 p.m. UTC | #2
On Thu, Sep 23 2021, Attila Lendvai wrote:

> * gnu/packages/finance.scm (trezor-gpg-pinentry-tk): New variable.
> ---
>  gnu/packages/finance.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
> index 4aaab58906..9b073541de 100644
> --- a/gnu/packages/finance.scm
> +++ b/gnu/packages/finance.scm
> @@ -884,6 +884,31 @@ the Monero GUI client.")
>  Ledger Nano as a hardware SSH/GPG agent.")
>      (license license:lgpl3)))
>  
> +(define-public trezor-gpg-pinentry-tk
> +  (package
> +    (name "trezor-gpg-pinentry-tk")
> +    (version "0.0.10")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/rendaw/trezor-gpg-pinentry-tk/")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1mblx4favmw4nf7k9rfl00ivv77kgdiwghyz4xv5cp0v410kjaqc"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-tkinter" ,python "tk")))
> +    (home-page "https://github.com/rendaw/trezor-gpg-pinentry-tk")
> +    (synopsis "A GPG PIN entry program for use with trezor-agent
> +or for people with number-only PINs.")

The synopsis starts with an article, and it is a bit long (see “16.4.4
Synopses and Descriptions” in the manual for more details), I suggest

  GPG pinentry program for use with @code{trezor-agent}

> +    (description
> +     "An alternate PIN entry for use with trezor-agent, or for people
> +with number-only PINs. It displays a grid of unlabeled buttons and
> +supports configurable keyboard mappings.")

The first sentence lacks a subject, and there should be two spaces after
a period.  I suggest

  This package provides a GPG pinentry program for use with
  @code{trezor-agent}, or for people with number-only PINs.  It displays
  a grid of unlabeled buttons and supports configurable keyboard
  settings.


> +    (license license:lgpl3)))

The ‘license.txt’ file says BSD-2.

Could you send an updated patch?
Attila Lendvai Sept. 28, 2021, 12:47 a.m. UTC | #3
please ignore the 4-part unrelated patch series, i have sent them to the wrong address... :/

sorry for the mess! i'm still learning this alien workflow.

- attila
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 4aaab58906..9b073541de 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -884,6 +884,31 @@  the Monero GUI client.")
 Ledger Nano as a hardware SSH/GPG agent.")
     (license license:lgpl3)))
 
+(define-public trezor-gpg-pinentry-tk
+  (package
+    (name "trezor-gpg-pinentry-tk")
+    (version "0.0.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rendaw/trezor-gpg-pinentry-tk/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mblx4favmw4nf7k9rfl00ivv77kgdiwghyz4xv5cp0v410kjaqc"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-tkinter" ,python "tk")))
+    (home-page "https://github.com/rendaw/trezor-gpg-pinentry-tk")
+    (synopsis "A GPG PIN entry program for use with trezor-agent
+or for people with number-only PINs.")
+    (description
+     "An alternate PIN entry for use with trezor-agent, or for people
+with number-only PINs. It displays a grid of unlabeled buttons and
+supports configurable keyboard mappings.")
+    (license license:lgpl3)))
+
 (define-public python-mnemonic
   (package
     (name "python-mnemonic")