diff mbox series

[bug#50722] gnu: Update amsynth to 1.12.2

Message ID 20210921141701.6928-1-thomas@thomaslabs.org
State Accepted
Headers show
Series [bug#50722] gnu: Update amsynth to 1.12.2 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola Sept. 21, 2021, 2:17 p.m. UTC
---
 gnu/packages/music.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Efraim Flashner Sept. 26, 2021, 5:24 p.m. UTC | #1
Couple of comments about the patch:

gsettings-desktop-schemas don't seem to be needed at build time, and it
launched fine for me when I removed it from the build entirely.

When I launuched it from the command line I got errors about not being
able to connect to lash.

Is the lash bit a regression from the currently packaged version? Are
you sure gsettings-desktop-schemas is actually needed?

Thanks.


On Tue, Sep 21, 2021 at 04:17:01PM +0200, Thomas Albers via Guix-patches via wrote:
> ---
>  gnu/packages/music.scm | 12 +++++++-----
>  1 file changed, 7 insertions(+), 5 deletions(-)
> 
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index ff1330d228..fe64b2af1b 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -43,6 +43,7 @@
>  ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>  ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
>  ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
>  (define-public amsynth
>    (package
>      (name "amsynth")
> -    (version "1.7.1")
> +    (version "1.12.2")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/amsynth/amsynth/releases/"
>                             "download/release-" version
> -                           "/amsynth-" version ".tar.bz2"))
> +                           "/amsynth-" version ".tar.gz"))
>         (sha256
>          (base32
> -         "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
> +         "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
>      (build-system gnu-build-system)
>      (arguments
>       `(#:phases
> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>             (lambda _
>               (substitute* "src/GUI/editor_pane.c"
>                 (("/usr/bin/unzip") (which "unzip")))
> -             (substitute* "src/GUI/GUI.cc"
> +             (substitute* "src/GUI/MainMenu.cpp"
>                 (("/usr/bin/which") (which "which")))
>               #t)))))
>      (inputs
>       `(("alsa-lib" ,alsa-lib)
>         ("gtk+" ,gtk+-2)
> -       ("gtkmm" ,gtkmm-2)
>         ("jack" ,jack-1)
>         ("lash" ,lash)
>         ("libsndfile" ,libsndfile)
> @@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
>         ;; External commands invoked at run time.
>         ("unzip" ,unzip)
>         ("which" ,which)))
> +    (propagated-inputs
> +     `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
>      (native-inputs
>       `(("intltool" ,intltool)
>         ("pkg-config" ,pkg-config)))
> -- 
> 2.33.0
> 
> 
> 
>
Thomas Albers Raviola Sept. 26, 2021, 8:17 p.m. UTC | #2
Hello Efraim,

thank you for your comments.

Yes `gsettings-desktop-schemas' is actually needed to avoid a running
time error on systems that do not include the package inside the profile
in which amsynth is installed.

It is also important for it to be a `propagated-input'. That way guix
updates the GLib schema cache.

For example, I run a desktop environment without login manager (dwm
lanched with a custom startx script). As such the following runtime
error is generated:

  GLib-GIO-ERROR **: 22:14:48.344: Settings schema
  'org.gnome.desktop.interface' is not installed

This error is most likely generated inside the function
`get_scaling_factor ()' at line 293 from editor_pane.c

About you other comment. I failed to notice the LASH problem. Mainly
because the program still works. I'll look into it.

> [[PGP Signed Part:Undecided]]
> Couple of comments about the patch:
>
> gsettings-desktop-schemas don't seem to be needed at build time, and it
> launched fine for me when I removed it from the build entirely.
>
> When I launuched it from the command line I got errors about not being
> able to connect to lash.
>
> Is the lash bit a regression from the currently packaged version? Are
> you sure gsettings-desktop-schemas is actually needed?
>
> Thanks.
>
>
> On Tue, Sep 21, 2021 at 04:17:01PM +0200, Thomas Albers via Guix-patches via wrote:
>> ---
>>  gnu/packages/music.scm | 12 +++++++-----
>>  1 file changed, 7 insertions(+), 5 deletions(-)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index ff1330d228..fe64b2af1b 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -43,6 +43,7 @@
>>  ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>>  ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
>>  ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
>> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
>>  (define-public amsynth
>>    (package
>>      (name "amsynth")
>> -    (version "1.7.1")
>> +    (version "1.12.2")
>>      (source
>>       (origin
>>         (method url-fetch)
>>         (uri (string-append "https://github.com/amsynth/amsynth/releases/"
>>                             "download/release-" version
>> -                           "/amsynth-" version ".tar.bz2"))
>> +                           "/amsynth-" version ".tar.gz"))
>>         (sha256
>>          (base32
>> -         "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
>> +         "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
>>      (build-system gnu-build-system)
>>      (arguments
>>       `(#:phases
>> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>>             (lambda _
>>               (substitute* "src/GUI/editor_pane.c"
>>                 (("/usr/bin/unzip") (which "unzip")))
>> -             (substitute* "src/GUI/GUI.cc"
>> +             (substitute* "src/GUI/MainMenu.cpp"
>>                 (("/usr/bin/which") (which "which")))
>>               #t)))))
>>      (inputs
>>       `(("alsa-lib" ,alsa-lib)
>>         ("gtk+" ,gtk+-2)
>> -       ("gtkmm" ,gtkmm-2)
>>         ("jack" ,jack-1)
>>         ("lash" ,lash)
>>         ("libsndfile" ,libsndfile)
>> @@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
>>         ;; External commands invoked at run time.
>>         ("unzip" ,unzip)
>>         ("which" ,which)))
>> +    (propagated-inputs
>> +     `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
>>      (native-inputs
>>       `(("intltool" ,intltool)
>>         ("pkg-config" ,pkg-config)))
>> --
>> 2.33.0
>>
>>
>>
>>
M Sept. 26, 2021, 8:19 p.m. UTC | #3
Thomas Albers via Guix-patches via schreef op di 21-09-2021 om 16:17 [+0200]:
> 
> [...]
>      (arguments
>       `(#:phases
> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>             (lambda _
>               (substitute* "src/GUI/editor_pane.c"
>                 (("/usr/bin/unzip") (which "unzip")))

Needs to be (string-append (assoc-ref inputs "unzip") "/bin/unzip")
for cross-compilation.

> -             (substitute* "src/GUI/GUI.cc"
> +             (substitute* "src/GUI/MainMenu.cpp"
>                 (("/usr/bin/which") (which "which")))

Likewise.

Greetings,
Maxime.
Thomas Albers Raviola Sept. 26, 2021, 8:41 p.m. UTC | #4
Hello Maxime,

you are completely right. I wanted to avoid making more modification
than needed to get the program to work because of my inexperience
submitting patches. I will take it into account now that I have to look
into an error I missed.

Greetings,
Thomas.

Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
> Thomas Albers via Guix-patches via schreef op di 21-09-2021 om 16:17 [+0200]:
>>
>> [...]
>>      (arguments
>>       `(#:phases
>> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>>             (lambda _
>>               (substitute* "src/GUI/editor_pane.c"
>>                 (("/usr/bin/unzip") (which "unzip")))
>
> Needs to be (string-append (assoc-ref inputs "unzip") "/bin/unzip")
> for cross-compilation.
>
>> -             (substitute* "src/GUI/GUI.cc"
>> +             (substitute* "src/GUI/MainMenu.cpp"
>>                 (("/usr/bin/which") (which "which")))
>
> Likewise.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
Thomas Albers Raviola Sept. 30, 2021, 10:43 p.m. UTC | #5
Hello Efraim,

I've found the cause for the LASH runtime error. LASH was never used by
amsynth.

As of version 1.7.1 the `lash.c` source file had a `#ifdef WITH_LASH`
block for enabling lash support, WITH_LASH was however never defined.
This can be easily checked by adding `#error "LASH is actually being
used"` immediately after the #ifdef.

Starting with version 1.9 the lash related functions actually get
included into the binary and cause the error complaining about the lash
server not being available.

Because LASH was never used to begin with, I've decided to remove it.
I am sending a new patch including this changes.

Greetings,
Thomas

Efraim Flashner <efraim@flashner.co.il> writes:

> [[PGP Signed Part:Undecided]]
> Couple of comments about the patch:
>
> gsettings-desktop-schemas don't seem to be needed at build time, and it
> launched fine for me when I removed it from the build entirely.
>
> When I launuched it from the command line I got errors about not being
> able to connect to lash.
>
> Is the lash bit a regression from the currently packaged version? Are
> you sure gsettings-desktop-schemas is actually needed?
>
> Thanks.
>
>
> On Tue, Sep 21, 2021 at 04:17:01PM +0200, Thomas Albers via Guix-patches via wrote:
>> ---
>>  gnu/packages/music.scm | 12 +++++++-----
>>  1 file changed, 7 insertions(+), 5 deletions(-)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index ff1330d228..fe64b2af1b 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -43,6 +43,7 @@
>>  ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>>  ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
>>  ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
>> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
>>  (define-public amsynth
>>    (package
>>      (name "amsynth")
>> -    (version "1.7.1")
>> +    (version "1.12.2")
>>      (source
>>       (origin
>>         (method url-fetch)
>>         (uri (string-append "https://github.com/amsynth/amsynth/releases/"
>>                             "download/release-" version
>> -                           "/amsynth-" version ".tar.bz2"))
>> +                           "/amsynth-" version ".tar.gz"))
>>         (sha256
>>          (base32
>> -         "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
>> +         "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
>>      (build-system gnu-build-system)
>>      (arguments
>>       `(#:phases
>> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>>             (lambda _
>>               (substitute* "src/GUI/editor_pane.c"
>>                 (("/usr/bin/unzip") (which "unzip")))
>> -             (substitute* "src/GUI/GUI.cc"
>> +             (substitute* "src/GUI/MainMenu.cpp"
>>                 (("/usr/bin/which") (which "which")))
>>               #t)))))
>>      (inputs
>>       `(("alsa-lib" ,alsa-lib)
>>         ("gtk+" ,gtk+-2)
>> -       ("gtkmm" ,gtkmm-2)
>>         ("jack" ,jack-1)
>>         ("lash" ,lash)
>>         ("libsndfile" ,libsndfile)
>> @@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
>>         ;; External commands invoked at run time.
>>         ("unzip" ,unzip)
>>         ("which" ,which)))
>> +    (propagated-inputs
>> +     `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
>>      (native-inputs
>>       `(("intltool" ,intltool)
>>         ("pkg-config" ,pkg-config)))
>> --
>> 2.33.0
>>
>>
>>
>>
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ff1330d228..fe64b2af1b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -43,6 +43,7 @@ 
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2354,16 +2355,16 @@  special variant of additive synthesis.")
 (define-public amsynth
   (package
     (name "amsynth")
-    (version "1.7.1")
+    (version "1.12.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/amsynth/amsynth/releases/"
                            "download/release-" version
-                           "/amsynth-" version ".tar.bz2"))
+                           "/amsynth-" version ".tar.gz"))
        (sha256
         (base32
-         "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
+         "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -2372,13 +2373,12 @@  special variant of additive synthesis.")
            (lambda _
              (substitute* "src/GUI/editor_pane.c"
                (("/usr/bin/unzip") (which "unzip")))
-             (substitute* "src/GUI/GUI.cc"
+             (substitute* "src/GUI/MainMenu.cpp"
                (("/usr/bin/which") (which "which")))
              #t)))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("gtk+" ,gtk+-2)
-       ("gtkmm" ,gtkmm-2)
        ("jack" ,jack-1)
        ("lash" ,lash)
        ("libsndfile" ,libsndfile)
@@ -2386,6 +2386,8 @@  special variant of additive synthesis.")
        ;; External commands invoked at run time.
        ("unzip" ,unzip)
        ("which" ,which)))
+    (propagated-inputs
+     `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
     (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))