diff mbox series

[bug#50712] gnu: Update python-mypy to 0.910.

Message ID 20210921011319.31bb9708@riseup.net
State Accepted
Headers show
Series [bug#50712] gnu: Update python-mypy to 0.910. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Sept. 20, 2021, 11:13 p.m. UTC
* gnu/packages/python-check.scm (python-mypy): Update to 0.910.
[arguments]: Make --without-tests work with custom check phase.
[propagated-inputs]: Add python-toml to fix missing import in mypyc.
---
 gnu/packages/python-check.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Sept. 26, 2021, 5:51 p.m. UTC | #1
Thanks. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm
b/gnu/packages/python-check.scm index b8d63b8479..eeaedb9927 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1343,7 +1343,7 @@  supported by the MyPy typechecker.")
 (define-public python-mypy
   (package
     (name "python-mypy")
-    (version "0.790")
+    (version "0.910")
     (source
      (origin
        ;; Because of https://github.com/python/mypy/issues/9584, the
@@ -1360,14 +1360,15 @@  supported by the MyPy typechecker.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0zq3lpdf9hphcklk40wz444h8w3dkhwa12mqba5j9lmg11klnhz7"))))
+         "16ryn9d48ilcs3yrkrm9ynx36qnv0gkdkc4sbafpagcqgr2f0mrg"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "pytest" "mypyc"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "mypyc")))))))
     (native-inputs
      `(("python-attrs" ,python-attrs)
        ("python-flake8" ,python-flake8)
@@ -1383,6 +1384,7 @@  supported by the MyPy typechecker.")
        ("python-virtualenv" ,python-virtualenv)))
     (propagated-inputs
      `(("python-mypy-extensions" ,python-mypy-extensions)
+       ("python-toml" ,python-toml)
        ("python-typing-extensions" ,python-typing-extensions)
        ("python-typed-ast" ,python-typed-ast)))
     (home-page "http://www.mypy-lang.org/")