diff mbox series

[bug#50703,core-updates-frozen] gnu: 4dtris: Fix build.

Message ID 20210920193749.44727-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#50703,core-updates-frozen] gnu: 4dtris: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 20, 2021, 7:37 p.m. UTC
* gnu/packages/games.scm (4dtris)[attributes]: Add -fcommon to CFLAGS
  and use search-input-directory to find SDL include path.
---
 gnu/packages/games.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Mathieu Othacehe Sept. 21, 2021, 1:50 p.m. UTC | #1
Hello,

Pushed as ea93dbbfc62db913fa7ea7860545226cf9745fef, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 88a589551d..e279e1eb71 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8639,7 +8639,8 @@  affected by the gravity of the planets.")
          "1nfkhcm0l89jyw8yr65na97g4l385zhjf7whkyg47c3v5sdqq2g7"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("CFLAGS=-fcommon")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-install-directories
            (lambda* (#:key outputs #:allow-other-keys)
@@ -8656,7 +8657,7 @@  affected by the gravity of the planets.")
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "CPATH"
                      (string-append
-                      (search-input-file inputs "/include/SDL")
+                      (search-input-directory inputs "/include/SDL")
                       ":" (or (getenv "CPATH") ""))))))))
     (inputs
      `(("fontconfig" ,fontconfig)