diff mbox series

[bug#50662,v2,29/34] gnu: Add rust-aes-soft-0.6.

Message ID 20210918170332.213414-9-monego@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

Vinicius Monego Sept. 18, 2021, 5:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-aes-soft-0.6): New variable.
(rust-aes-soft-0.4): Inherit from above.
---
 gnu/packages/crates-io.scm | 35 +++++++++++++++++++++++++++++------
 1 file changed, 29 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 89d1ed62ea..25cab9eb40 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1274,21 +1274,21 @@  acceleration.")
         ("rust-subtle" ,rust-subtle-2)
         ("rust-zeroize" ,rust-zeroize-1))))))
 
-(define-public rust-aes-soft-0.4
+(define-public rust-aes-soft-0.6
   (package
     (name "rust-aes-soft")
-    (version "0.4.0")
+    (version "0.6.4")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "aes-soft" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "19szsg0qqxq42k7bj5p3svb147n8wxy9a20n4g7mcl2fwrz689a9"))))
+        (base32 "0wj0fi2pvmlw09yvb1aqf0mfkzrfxmjsf90finijh255ir4wf55y"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
+     `(#:skip-build? #t
+       #:cargo-inputs
        (("rust-block-cipher" ,rust-block-cipher-0.7)
         ("rust-byteorder" ,rust-byteorder-1)
         ("rust-opaque-debug" ,rust-opaque-debug-0.2))
@@ -1297,9 +1297,32 @@  acceleration.")
     (home-page "https://github.com/RustCrypto/block-ciphers")
     (synopsis "Bit-sliced implementation of AES (Rijndael) block ciphers")
     (description "This package provides a bit-sliced implementation of
-AES (Rijndael) block ciphers.")
+AES (Rijndael) block ciphers.
+
+This package is deprecated and was replaced by the @code{aes} crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-aes-soft-0.4
+  (package
+    (inherit rust-aes-soft-0.6)
+    (name "rust-aes-soft")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aes-soft" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "19szsg0qqxq42k7bj5p3svb147n8wxy9a20n4g7mcl2fwrz689a9"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-block-cipher" ,rust-block-cipher-0.7)
+        ("rust-byteorder" ,rust-byteorder-1)
+        ("rust-opaque-debug" ,rust-opaque-debug-0.2))
+       #:cargo-development-inputs
+       (("rust-block-cipher" ,rust-block-cipher-0.7))))))
+
 (define-public rust-aes-soft-0.3
   (package
     (inherit rust-aes-soft-0.4)