diff mbox series

[bug#50647,2/3] gnu: python-passlib: Use python-bcrypt.

Message ID 20210917175534.114800-2-monego@posteo.net
State Accepted
Headers show
Series Updates to python-passlib. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Sept. 17, 2021, 5:55 p.m. UTC
py-bcrypt is unmaintained and support will be dropped in passlib 1.8. The
recommended option is bcrypt.

* gnu/packages/python-crypto.scm (python-passlib)[propagated-inputs]: Remove
python-py-bcrypt. Add python-bcrypt.
[arguments]<#:phases>: Don't return #t.
---
Source: https://passlib.readthedocs.io/en/stable/install.html#optional-libraries

 gnu/packages/python-crypto.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index cbf563af42..bfc97e53b3 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -154,13 +154,13 @@  Password Scheme\"} by Niels Provos and David Mazieres.")
     (native-inputs
      `(("python-nose" ,python-nose)))
     (propagated-inputs
-     `(("python-py-bcrypt" ,python-py-bcrypt)))
+     `(("python-bcrypt" ,python-bcrypt)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-before 'check 'set-PYTHON_EGG_CACHE
            ;; Some tests require access to "$HOME/.cython".
-           (lambda _ (setenv "PYTHON_EGG_CACHE" "/tmp") #t)))))
+           (lambda _ (setenv "PYTHON_EGG_CACHE" "/tmp"))))))
     (home-page "https://bitbucket.org/ecollins/passlib")
     (synopsis "Comprehensive password hashing framework")
     (description