diff mbox series

[bug#50018,v3,08/21] gnu: awscli: Update to 1.20.42.

Message ID 20210916162112.54462-9-monego@posteo.net
State Accepted
Headers show
Series Update Celery to version 5. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Sept. 16, 2021, 4:20 p.m. UTC
* gnu/packages/python-web.scm (awscli): Update to 1.20.42.
[arguments]<#:phases>: Don't return #t.
---
 gnu/packages/python-web.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bb42c3b136..5449911f3f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2854,14 +2854,14 @@  supports url redirection and retries, and also gzip and deflate decoding.")
   (package
     ;; Note: updating awscli typically requires updating botocore as well.
     (name "awscli")
-    (version "1.18.203")
+    (version "1.20.42")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri name version))
        (sha256
         (base32
-         "128zg24961j8nmnq2dxqg6a7zwh3qgv87cmvclsdqwwih9nigxv9"))))
+         "0fzlf42by4xxl23higfcgdjpcpi7fp9mrxpwkwn13wxhki4p7x96"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: The 'pypi' release does not contain tests.
@@ -2874,8 +2874,7 @@  supports url redirection and retries, and also gzip and deflate decoding.")
                (("if not self._exists_on_path\\('groff'\\):") "")
                (("raise ExecutableNotFoundError\\('groff'\\)") "")
                (("cmdline = \\['groff'")
-                (string-append "cmdline = ['" (which "groff") "'")))
-             #t)))))
+                (string-append "cmdline = ['" (which "groff") "'"))))))))
     (propagated-inputs
      `(("python-colorama" ,python-colorama)
        ("python-botocore" ,python-botocore)