diff mbox series

[bug#50018,v3,10/21] gnu: python-moto: Update to 2.2.7.

Message ID 20210916162112.54462-11-monego@posteo.net
State Accepted
Headers show
Series Update Celery to version 5. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Sept. 16, 2021, 4:21 p.m. UTC
* gnu/packages/python-xyz.scm (python-moto): Update to 2.2.7.
[arguments]: Make some cosmetic changes. Skip more tests. Don't return #t on
phases.
---
 gnu/packages/python-xyz.scm | 49 +++++++++++++++++++++----------------
 1 file changed, 28 insertions(+), 21 deletions(-)

Comments

M Sept. 26, 2021, 5:08 p.m. UTC | #1
Vinicius Monego schreef op do 16-09-2021 om 16:21 [+0000]:
> * gnu/packages/python-xyz.scm (python-moto): Update to 2.2.7.
> [arguments]: Make some cosmetic changes. Skip more tests. Don't return #t on
> phases.
> ---
>  gnu/packages/python-xyz.scm | 49 +++++++++++++++++++++----------------
>  1 file changed, 28 insertions(+), 21 deletions(-)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 2b737bc029..b2be163eec 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -12653,34 +12653,41 @@ text.")
>  (define-public python-moto
>    (package
>      (name "python-moto")
> -    ;; XXX: Use a pre-release for compatibility with latest botocore & friends.
> -    (version "1.3.16.dev134")
> +    (version "2.2.7")
>      (source (origin
>                (method url-fetch)
>                (uri (pypi-uri "moto" version))
>                (sha256
>                 (base32
> -                "1pix0c7zszjwzfy88n1rpih9vkdm25nqcvz93z850xvgwb4v81bd"))))
> +                "065m24x9d7vlmd7xfa9f5m7829axhq7r6mj5r44hi2bipv833lgm"))))
>      (build-system python-build-system)
>      (arguments
> -     `(#:phases (modify-phases %standard-phases
> -                  (add-after 'unpack 'patch-hardcoded-executable-names
> -                    (lambda _
> -                      (substitute* "moto/batch/models.py"
> -                        (("/bin/sh")
> -                         (which "sh")))
> -                      (substitute* (find-files "tests" "\\.py$")
> -                        (("#!/bin/bash")
> -                         (string-append "#!" (which "bash"))))
> -                      #t))
> -                  (replace 'check
> -                    (lambda _
> -                      (setenv "PYTHONPATH" (string-append "./build/lib:"
> -                                                          (getenv "PYTHONPATH")))
> -                      (invoke "pytest" "-vv" "-m" "not network"
> -                              ;; These tests require Docker.
> -                              "-k" "not test_terminate_job \
> -and not test_invoke_function_from_sqs_exception"))))))
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'patch-hardcoded-executable-names
> +           (lambda _
> +             (substitute* "moto/batch/models.py"
> +               (("/bin/sh")
> +                (which "sh")))

This needs to be something like (search-input-file "bin/sh") instead
for cross-compiling python-moto (though python-build-system doesn't
support cross-compilation currently), with "bash-minimal" added to the
inputs.

Or (string-append (assoc-ref inputs "bash-minimal") "/bin/sh"), because
search-input-file is only in core-updates and core-updates-frozen, and not
yet in master.

Greetings,
Maxime
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2b737bc029..b2be163eec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12653,34 +12653,41 @@  text.")
 (define-public python-moto
   (package
     (name "python-moto")
-    ;; XXX: Use a pre-release for compatibility with latest botocore & friends.
-    (version "1.3.16.dev134")
+    (version "2.2.7")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "moto" version))
               (sha256
                (base32
-                "1pix0c7zszjwzfy88n1rpih9vkdm25nqcvz93z850xvgwb4v81bd"))))
+                "065m24x9d7vlmd7xfa9f5m7829axhq7r6mj5r44hi2bipv833lgm"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'patch-hardcoded-executable-names
-                    (lambda _
-                      (substitute* "moto/batch/models.py"
-                        (("/bin/sh")
-                         (which "sh")))
-                      (substitute* (find-files "tests" "\\.py$")
-                        (("#!/bin/bash")
-                         (string-append "#!" (which "bash"))))
-                      #t))
-                  (replace 'check
-                    (lambda _
-                      (setenv "PYTHONPATH" (string-append "./build/lib:"
-                                                          (getenv "PYTHONPATH")))
-                      (invoke "pytest" "-vv" "-m" "not network"
-                              ;; These tests require Docker.
-                              "-k" "not test_terminate_job \
-and not test_invoke_function_from_sqs_exception"))))))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-hardcoded-executable-names
+           (lambda _
+             (substitute* "moto/batch/models.py"
+               (("/bin/sh")
+                (which "sh")))
+             (substitute* (find-files "tests" "\\.py$")
+               (("#!/bin/bash")
+                (string-append "#!" (which "bash"))))))
+         (replace 'check
+           (lambda _
+             (setenv "PYTHONPATH" (string-append "./build/lib:"
+                                                 (getenv "PYTHONPATH")))
+             (invoke "pytest" "-vv" "-m" "not network" "-k"
+                     (string-append
+                      ;; These tests require Docker.
+                      "not test_terminate_job"
+                      " and not test_invoke_function_from_sqs_exception"
+                      " and not test_rotate_secret_lambda_invocations"
+                      ;; ConnectionAborted errors.
+                      " and not test_put_record_batch_http_destination"
+                      " and not test_put_record_http_destination"
+                      " and not test_dependencies"
+                      " and not test_cancel_running_job"
+                      " and not test_container_overrides")))))))
     (native-inputs
      `(("python-flask" ,python-flask)
        ("python-flask-cors" ,python-flask-cors)