diff mbox series

[bug#50505,v2,08/13] gnu: Add python-screeninfo.

Message ID 20210915152519.25572-9-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series None | expand

Commit Message

Daniel Meißner Sept. 15, 2021, 3:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-screeninfo): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4fa193f47e..3a984eaa68 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19071,6 +19071,28 @@  Joysticks, OpenGL graphics, loading images and videos, and playing sounds and
 music.  All of this with a friendly Pythonic API that's simple to learn.")
     (license license:bsd-3)))
 
+(define-public python-screeninfo
+  (package
+   (name "python-screeninfo")
+   (version "0.7")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "screeninfo" version))
+     (sha256
+      (base32
+       "007m7sqv30qak56885dxbijksrg2hd121hfpvg2llm734wspra8j"))))
+   (build-system python-build-system)
+   (native-inputs `(("python-pytest" ,python-pytest)))
+   (home-page "https://github.com/rr-/screeninfo")
+   (synopsis
+    "Obtain information about physical screens")
+   (description
+    "This python module provides means to access information about physical
+screens like resolution, height and width of the screen, connecting port
+etc.")
+   (license (list license:expat license:bsd-3))))
+
 (define-public python-rencode
   (package
    (name "python-rencode")