diff mbox series

[bug#50505,v2,07/13] gnu: Add python-pyrr.

Message ID 20210915152519.25572-8-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series None | expand

Commit Message

Daniel Meißner Sept. 15, 2021, 3:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyrr): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f445e15bc..4fa193f47e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18990,6 +18990,29 @@  also written in C++ for high performance.")
 types more concise to write.")
     (license license:bsd-3)))
 
+(define-public python-pyrr
+  (package
+    (name "python-pyrr")
+    (version "0.10.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyrr" version))
+       (sha256
+        (base32
+         "07byxkq8dcc8n6fc2q7g3vq3mxzzj0hqzm8hlq3gfwbf68h7n3rw"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-multipledispatch" ,python-multipledispatch)
+       ("python-numpy" ,python-numpy)))
+    (home-page "https://github.com/adamlwgriffiths/Pyrr")
+    (synopsis "Mathematical functions for 3D graphics using NumPy")
+    (description
+     "This Python package provides a collection of object-oriented and
+procedural interfaces for working with matrices, quaternions, vectors and
+plane/line/ray objects for 3D graphics.")
+    (license license:bsd-2)))
+
 (define-public python-pyglet
   (package
     (name "python-pyglet")