diff mbox series

[bug#50531] gnu: libngspice: Update to 35.

Message ID 20210911224150.217797-1-monego@posteo.net
State Accepted
Headers show
Series [bug#50531] gnu: libngspice: Update to 35. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Sept. 11, 2021, 10:41 p.m. UTC
* gnu/packages/engineering.scm (libngspice): Update to 35.
[arguments]<#:phases>: Rename 'delete-scripts-and-config to 'delete-scripts
and don't try to delete config.h because that file was removed in this version.
---
 gnu/packages/engineering.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)

Comments

Mathieu Othacehe Sept. 21, 2021, 2:07 p.m. UTC | #1
> * gnu/packages/engineering.scm (libngspice): Update to 35.
> [arguments]<#:phases>: Rename 'delete-scripts-and-config to 'delete-scripts
> and don't try to delete config.h because that file was removed in this version.

Pushed as fa6a1f52b2a1e55770ac073884cb7146749d3e63.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 33c124a2ea..7950ea31ff 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1707,7 +1707,7 @@  high-performance parallel differential evolution (DE) optimization algorithm.")
   ;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
   (package
     (name "libngspice")
-    (version "34")
+    (version "35")
     (source
      (origin
        (method url-fetch)
@@ -1718,7 +1718,7 @@  high-performance parallel differential evolution (DE) optimization algorithm.")
                             "old-releases/" version
                             "/ngspice-" version ".tar.gz")))
        (sha256
-        (base32 "1dfpkgkwmgwhq8dnbb8dh28cfap6rw0yywkhmxr4jxclcvygyqr2"))))
+        (base32 "1v3ra9p2sc6ash1bbjm6i4i3dd6ymxjgnyha7z5rlmyvfv1gbdy1"))))
     (build-system gnu-build-system)
     (arguments
      `(;; No tests for libngspice exist.
@@ -1735,16 +1735,11 @@  high-performance parallel differential evolution (DE) optimization algorithm.")
              (substitute* "man/man1/Makefile.in"
                (("^man_MANS = ngspice\\.1 ngnutmeg\\.1 ngsconvert\\.1 ngmultidec\\.1")
                 "man_MANS = "))))
-         (add-after 'install 'delete-scripts-and-config
+         (add-after 'install 'delete-scripts
            (lambda* (#:key outputs #:allow-other-keys)
              (delete-file-recursively
               (string-append (assoc-ref outputs "out")
-                             "/share/ngspice/scripts"))
-             ;; This file is autogenerated by the configure script and should
-             ;; not be distributed.  It could be removed in ngspice 35.  See
-             ;; https://bugs.archlinux.org/task/70569 for reference.
-             (delete-file (string-append (assoc-ref outputs "out")
-                                         "/include/config.h")))))
+                             "/share/ngspice/scripts")))))
        #:configure-flags
        (list "--enable-openmp"
              "--enable-ciderlib"