diff mbox series

[bug#50524,core-updates-frozen] gnu: chocolate-doom: Fix compilation with GCC 10.

Message ID 20210911195020.43805-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#50524,core-updates-frozen] gnu: chocolate-doom: Fix compilation with GCC 10. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 11, 2021, 7:50 p.m. UTC
* gnu/packages/games.scm (chocolate-doom)[arguments]: Pass '-fcommon' to
  CFLAGS.
---
 gnu/packages/games.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Guillaume Le Vaillant Sept. 12, 2021, 7:44 a.m. UTC | #1
Patch pushed as 58d3c8bb1ee42bcca05ba05187748c9e130cab67.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e60987d834..410dccafdc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7467,6 +7467,8 @@  online.")
                (base32
                 "1iy8rx7kjvi1zjiw4zh77szzmd1sgpqajvbhprh1sj93fhbxcdfl"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags (list "CFLAGS=-fcommon")))
     (inputs `(("sdl2-net" ,sdl2-net)
               ("sdl2-mixer" , sdl2-mixer)
               ("sdl2" ,sdl2)))