diff mbox series

[bug#50517,core-updates-frozen] gnu: psm: Fix building with GCC 10.

Message ID 20210911084634.6997-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#50517,core-updates-frozen] gnu: psm: Fix building with GCC 10. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 11, 2021, 8:46 a.m. UTC
* gnu/packages/linux.scm (psm)[arguments]: Pass '-fcommon' to CFLAGS.
I had to copy all the CFLAGS that were originally defined by the
Makefile as they were otherwise all replaced by '-fcommon'.
---
 gnu/packages/linux.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Guillaume Le Vaillant Sept. 11, 2021, 9:23 a.m. UTC | #1
Patch pushed as abe4bdad800589a84d75903d5b85a1d798a6924a.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1305a80f56..122c2773fb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -56,6 +56,7 @@ 
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7256,6 +7257,11 @@  libraries, which are often integrated directly into libfabric.")
     (arguments
      '(#:make-flags `("PSM_USE_SYS_UUID=1" "CC=gcc" "WERROR="
                       ,(string-append "INSTALL_PREFIX=" %output)
+                      ,(string-append "CFLAGS=-Wall -fpic -fPIC -D_GNU_SOURCE"
+                                      " -funwind-tables -O3 -g3"
+                                      " -DPSM_USE_SYS_UUID"
+                                      " -Wno-strict-aliasing -DNVALGRIND"
+                                      " -fcommon")
                       ,(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
        #:tests? #f
        #:phases (modify-phases %standard-phases