diff mbox series

[bug#50513] gnu: nestopia-ue: Update to 1.51.1.

Message ID 20210910210235.55759-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#50513] gnu: nestopia-ue: Update to 1.51.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 10, 2021, 9:02 p.m. UTC
* gnu/packages/emulators.scm (nestopia-ue): Update to 1.51.1.
[source]: libretro is not included in nestopia-ue anymore.
[build-system]: Change to gnu-build-system.
[native-inputs]: Add autoconf, autoconf-archive and automake.
[inputs]: Remove ao and gtk+, add fltk, fontconfig, libxft and
libxrender.
[arguments]: Remove 'wrap-program phase which was needed for the removed
gtk+ dependency.
---
 gnu/packages/emulators.scm | 37 +++++++++++++------------------------
 1 file changed, 13 insertions(+), 24 deletions(-)

Comments

M Sept. 13, 2021, 12:42 p.m. UTC | #1
Felix Gruber schreef op vr 10-09-2021 om 21:02 [+0000]:
>      (arguments
> -     '(#:phases
> -       (modify-phases %standard-phases
> -         ;; This fixes the file chooser crash that happens with GTK 3.
> -         (add-after 'install 'wrap-program
> -           (lambda* (#:key inputs outputs #:allow-other-keys)
> -             (let* ((out (assoc-ref outputs "out"))
> -                    (nestopia (string-append out "/bin/nestopia"))
> -                    (gtk (assoc-ref inputs "gtk+"))
> -                    (gtk-share (string-append gtk "/share")))
> -               (wrap-program nestopia
> -                 `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))

Does nestopia-eu start with
"guix environment --ad-hoc nestopia-eu --pure -- nestopia"
when removing 'wrap-program'?  If not, the wrap-program is probably
still necessary.

Greetings,
Maxime.
Felix Gruber Sept. 13, 2021, 4:51 p.m. UTC | #2
On 9/13/21 2:42 PM, Maxime Devos wrote:
> Does nestopia-eu start with
> "guix environment --ad-hoc nestopia-eu --pure -- nestopia"
> when removing 'wrap-program'?  If not, the wrap-program is probably
> still necessary.

I confirm that nestopia does run with

guix environment --ad-hoc nestopia-ue --pure -- nestopia

It seems to function normally when started that way.

Best,
Felix
宋文武 Sept. 19, 2021, 1:03 p.m. UTC | #3
Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 28ecb0c563..3393506c0e 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -59,6 +59,7 @@ 
   #:use-module (gnu packages digest)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages fltk)
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
@@ -1369,7 +1370,7 @@  towards a working Mupen64Plus for casual users.")
 (define-public nestopia-ue
   (package
     (name "nestopia-ue")
-    (version "1.48")
+    (version "1.51.1")
     (source
      (origin
        (method git-fetch)
@@ -1378,36 +1379,24 @@  towards a working Mupen64Plus for casual users.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "19c8vx5yxbysl0sszk5blfngwacshdgwbf44g1qaxvq8ywiyxmb4"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; We don't need libretro for the GNU/Linux build.
-           (delete-file-recursively "libretro")
-           #t))))
-    (build-system cmake-build-system)
+        (base32 "1g19gz33jav00rwzkpcnynf5ps41vl64a9qx0xjd6lva4bgn8s57"))))
+    (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("autoconf" ,autoconf)
+       ("autoconf-archive" ,autoconf-archive)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
     (inputs
-     `(("ao" ,ao)
-       ("gtk+" ,gtk+)
+     `(("fltk" ,fltk)
+       ("fontconfig", fontconfig)
        ("libarchive" ,libarchive)
        ("libepoxy" ,libepoxy)
+       ("libxft" ,libxft)
+       ("libxrender" ,libxrender)
        ("sdl2" ,sdl2)
        ("zlib" ,zlib)))
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         ;; This fixes the file chooser crash that happens with GTK 3.
-         (add-after 'install 'wrap-program
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (nestopia (string-append out "/bin/nestopia"))
-                    (gtk (assoc-ref inputs "gtk+"))
-                    (gtk-share (string-append gtk "/share")))
-               (wrap-program nestopia
-                 `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))
-       ;; There are no tests.
+     '(;; There are no tests.
        #:tests? #f))
     (home-page "http://0ldsk00l.ca/nestopia/")
     (synopsis "Nintendo Entertainment System (NES/Famicom) emulator")