diff mbox series

[bug#50428] gnu: Add cryfs

Message ID 20210906133437.3691-1-mail@brendan.scot
State Accepted
Headers show
Series [bug#50428] gnu: Add cryfs | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley Sept. 6, 2021, 1:34 p.m. UTC
* gnu/packages/crypto.scm (cryfs): New variable.
---
 gnu/packages/crypto.scm | 75 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 75 insertions(+)

Comments

Ludovic Courtès Sept. 14, 2021, 9:50 a.m. UTC | #1
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

> * gnu/packages/crypto.scm (cryfs): New variable.

Overall LGTM modulo the minor issues below:

> +     '(#:configure-flags
> +       `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
> +         "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.

Normally this is set by #:build-type.  It defaults to “RelWithDebInfo”,
which is nice because then you get debugging symbols if you pass
‘--with-debug-info=cryfs’.  So I’d suggest removing this second flag.

> +         (replace 'check
> +           (lambda* (#:key tests? outputs #:allow-other-keys)
> +             (use-modules (srfi srfi-1))

Please use #:modules ((srfi srfi-1) …) instead of this non-top-level
‘use-modules’ form.

> +             (when tests?
> +               (with-directory-excursion "/tmp/build/test"
> +                 (let ((tests (find-files "." "-test$"))
> +                       (tests-output (assoc-ref outputs "tests")))
> +                   ;; Install tests to a separate output so users can run them.
> +                   (copy-recursively "." tests-output)

Installing tests is unusual.  Do you really think it’s going to be
useful?

> +                   ;; XXX: Disable failing tests. Unfortunately there are a
> +                   ;; few. Some only fail in the build environment. ;; build
> +                   ;; environment.

Typo.

> +    (description "CryFS encrypts your files, so you can safely store them anywhere.
> + It works well together with cloud services like Dropbox, iCloud, OneDrive and
   ^
Extra space.  :-)

Could you send an updated patch?

Thanks!

Ludo’.
Ludovic Courtès Sept. 16, 2021, 9:42 a.m. UTC | #2
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

> * gnu/packages/crypto.scm (cryfs): New variable.

Overall LGTM modulo the minor issues below:

> +     '(#:configure-flags
> +       `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
> +         "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.

Normally this is set by #:build-type.  It defaults to “RelWithDebInfo”,
which is nice because then you get debugging symbols if you pass
‘--with-debug-info=cryfs’.  So I’d suggest removing this second flag.

> +         (replace 'check
> +           (lambda* (#:key tests? outputs #:allow-other-keys)
> +             (use-modules (srfi srfi-1))

Please use #:modules ((srfi srfi-1) …) instead of this non-top-level
‘use-modules’ form.

> +             (when tests?
> +               (with-directory-excursion "/tmp/build/test"
> +                 (let ((tests (find-files "." "-test$"))
> +                       (tests-output (assoc-ref outputs "tests")))
> +                   ;; Install tests to a separate output so users can run them.
> +                   (copy-recursively "." tests-output)

Installing tests is unusual.  Do you really think it’s going to be
useful?

> +                   ;; XXX: Disable failing tests. Unfortunately there are a
> +                   ;; few. Some only fail in the build environment. ;; build
> +                   ;; environment.

Typo.

> +    (description "CryFS encrypts your files, so you can safely store them anywhere.
> + It works well together with cloud services like Dropbox, iCloud, OneDrive and
   ^
Extra space.  :-)

Could you send an updated patch?

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c511d0a711..7f4f8590f5 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,8 +47,10 @@ 
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages cryptsetup)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnupg)
@@ -58,6 +61,7 @@ 
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages logging)
   #:use-module (gnu packages lsof)
   #:use-module (gnu packages man)
   #:use-module (gnu packages multiprecision)
@@ -1385,3 +1389,74 @@  them out.  The process will degrade gracefully, so even people without your
 encryption password can safely commit changes to the repository's
 non-encrypted files.")
     (license license:expat)))
+
+(define-public cryfs
+  (package
+    (name "cryfs")
+    (version "0.11.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/cryfs/cryfs/releases/download/"
+             version "/cryfs-" version ".tar.xz"))
+       (sha256
+        (base32 "0dxphbj5sssm82rkkdb71algrcki16qlpzlvrjyvvm6b7x7zi0sm"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags
+       `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
+         "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.
+         ;; This helps us use some dependencies from Guix instead of conan.
+         ;; crypto++ is still bundled: https://github.com/cryfs/cryfs/issues/369
+         ,(string-append "-DDEPENDENCY_CONFIG=" (getcwd)
+                         "/cmake-utils/DependenciesFromLocalSystem.cmake"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-configure
+           (lambda* (#:key tests? #:allow-other-keys)
+             (chdir "..")
+             (delete-file-recursively ".circleci")
+             (when tests?
+               (substitute* "CMakeLists.txt"
+                 (("option.BUILD_TESTING .build test cases. OFF.")
+                  "option(BUILD_TESTING \"build test cases\" ON)")))))
+         (replace 'check
+           (lambda* (#:key tests? outputs #:allow-other-keys)
+             (use-modules (srfi srfi-1))
+             (when tests?
+               (with-directory-excursion "/tmp/build/test"
+                 (let ((tests (find-files "." "-test$"))
+                       (tests-output (assoc-ref outputs "tests")))
+                   ;; Install tests to a separate output so users can run them.
+                   (copy-recursively "." tests-output)
+                   ;; XXX: Disable failing tests. Unfortunately there are a
+                   ;; few. Some only fail in the build environment. ;; build
+                   ;; environment.
+                   (for-each invoke
+                             (lset-difference string-contains
+                                              tests
+                                              '("cpp-utils-test"
+                                                "cryfs-cli-test"
+                                                "blobstore-test"
+                                                "fspp-test"))))))
+             #t)))))
+    (outputs '("out" "tests"))
+    (native-inputs
+     `(("python" ,python-wrapper)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("boost" ,boost)
+       ("curl" ,curl)
+       ("fuse" ,fuse)
+       ("range-v3" ,range-v3)
+       ("spdlog" ,spdlog)))
+    (home-page "https://www.cryfs.org/")
+    (synopsis "Encrypted FUSE filesystem for the cloud")
+    (description "CryFS encrypts your files, so you can safely store them anywhere.
+ It works well together with cloud services like Dropbox, iCloud, OneDrive and
+others.  CryFS creates an encrypted userspace filesystem that can be mounted
+via FUSE without root permissions.  It is similar to EncFS, but provides
+additional security and privacy measures such as hiding file sizes and directory
+structure.  However CryFS is not considered stable yet by the developers.")
+    (license license:lgpl3+)))