diff mbox series

[bug#50419,2/2] gnu: racket: suppress build stamp

Message ID 20210906045903.478751-2-philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: racket: fix `raco exe` with non-minimal Racket | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath Sept. 6, 2021, 4:59 a.m. UTC
The `build-stamp` configuration key should generally be set to an empty
string for a release build. The automatically inferred build stamp is
especially unhelpful with Guix, since it ends up being the Unix epoch.

* gnu/packages/racket.scm (racket-minimal)[arguments]: Adjust the
'initialize-config.rktd phase to set 'build-stamp to "".
---
 gnu/packages/racket.scm | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index a05d435303..e150f96575 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -214,6 +214,7 @@ 
                                                    "/lib"))
                                   '("openssl"
                                     "sqlite"))))
+                    (build-stamp . "")
                     (catalogs
                      . (,(string-append
                           "https://download.racket-lang.org/releases/"