diff mbox series

[bug#50375] gnu: Add mlterm.

Message ID 20210904164205.12031-1-ahmed@ikasero.com
State Accepted
Headers show
Series [bug#50375] gnu: Add mlterm. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

iKaSeRo Sept. 4, 2021, 4:42 p.m. UTC
* gnu/packages/terminals.scm (mlterm): New variable.
---
 gnu/packages/terminals.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Xinglu Chen Sept. 4, 2021, 7:50 p.m. UTC | #1
On Sat, Sep 04 2021, iKaSeRo wrote:

> * gnu/packages/terminals.scm (mlterm): New variable.
> ---
>  gnu/packages/terminals.scm | 40 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
> index 1cdf0e1831..037504ee4f 100644
> --- a/gnu/packages/terminals.scm
> +++ b/gnu/packages/terminals.scm
> @@ -25,6 +25,7 @@
>  ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>  ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
>  ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
> +;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -66,6 +67,7 @@
>    #:use-module (gnu packages docbook)
>    #:use-module (gnu packages fontutils)
>    #:use-module (gnu packages freedesktop)
> +  #:use-module (gnu packages fribidi)
>    #:use-module (gnu packages gettext)
>    #:use-module (gnu packages ghostscript)
>    #:use-module (gnu packages gl)
> @@ -1458,3 +1460,41 @@ ephemeral serial ports.  It features automatic port detection, port enumeration,
>  support for non-standard baud rates, the ability to wait for ports to appear,
>  and the ability to read and write via stdin and stdout.")
>      (license license:expat)))
> +
> +(define-public mlterm
> +  (package
> +    (name "mlterm")
> +    (version "3.9.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "mirror://sourceforge/mlterm/01release/mlterm-"
> +                           version "/mlterm-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "03fnynwv7d1aicwk2rp31sgncv5m65agvygqvsgn59v9di40gnnb"))))
> +    (build-system gnu-build-system)
> +    (arguments `(#:tests? #f

What’s the reason for disabling tests; there should be a comment with a
short explanation.

Nit: This is usually on its own line

  (arguments
   `(#:tests? #f
     #:configure-flags
     ...))

> +                 #:configure-flags
> +                 (list (string-append "--prefix=" (assoc-ref %outputs "out"))
> +                       "--disable-static"
> +                       "--enable-optimize-redrawing"
> +                       "--with-imagelib=gdk-pixbuf")))
> +    (native-inputs
> +     `(("gettext" ,gettext-minimal)
> +       ("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("cairo" ,cairo)
> +       ("fontconfig" ,fontconfig)
> +       ("freetype" ,freetype)
> +       ("fribidi" ,fribidi)
> +       ("gdk-pixbuf" ,gdk-pixbuf)
> +       ("gtk+" ,gtk+)
> +       ("libx11" ,libx11)
> +       ("libxext" ,libxext)
> +       ("libxft" ,libxft)))
> +    (home-page "http://mlterm.sourceforge.net/")
> +    (synopsis "Multi Lingual TERMinal emulator")
> +    (description "mlterm is a multi-lingual terminal emulator which supports
> +various character sets and encodings in the world.")
> +    (license license:bsd-3)))
> -- 
> 2.33.0

The package builds fine, and the rest LGTM!
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 1cdf0e1831..037504ee4f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -66,6 +67,7 @@ 
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
@@ -1458,3 +1460,41 @@  ephemeral serial ports.  It features automatic port detection, port enumeration,
 support for non-standard baud rates, the ability to wait for ports to appear,
 and the ability to read and write via stdin and stdout.")
     (license license:expat)))
+
+(define-public mlterm
+  (package
+    (name "mlterm")
+    (version "3.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/mlterm/01release/mlterm-"
+                           version "/mlterm-" version ".tar.gz"))
+       (sha256
+        (base32
+         "03fnynwv7d1aicwk2rp31sgncv5m65agvygqvsgn59v9di40gnnb"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f
+                 #:configure-flags
+                 (list (string-append "--prefix=" (assoc-ref %outputs "out"))
+                       "--disable-static"
+                       "--enable-optimize-redrawing"
+                       "--with-imagelib=gdk-pixbuf")))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
+       ("fribidi" ,fribidi)
+       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gtk+" ,gtk+)
+       ("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxft" ,libxft)))
+    (home-page "http://mlterm.sourceforge.net/")
+    (synopsis "Multi Lingual TERMinal emulator")
+    (description "mlterm is a multi-lingual terminal emulator which supports
+various character sets and encodings in the world.")
+    (license license:bsd-3)))