diff mbox series

[bug#50365] gnu: Add slurm-monitor.

Message ID 20210903232652.998588-1-milkeymouse@meme.institute
State Accepted
Headers show
Series [bug#50365] gnu: Add slurm-monitor. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Milkey Mouse Sept. 3, 2021, 11:26 p.m. UTC
* gnu/packages/networking.scm (slurm-monitor): New variable.
---
 gnu/packages/networking.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Sept. 7, 2021, 12:42 p.m. UTC | #1
Hello,

Milkey Mouse <milkeymouse@meme.institute> writes:

> * gnu/packages/networking.scm (slurm-monitor): New variable.

I tweaked the description, add a copyright line for you, and applied
your patch. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 204ef167c6..f1b98381dd 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -384,6 +384,30 @@  supported, including rtmp://, rtmpt://, rtmpe://, rtmpte://, and rtmps://.")
         ;; Others.
         license:gpl2+)))))
 
+(define-public slurm-monitor
+  (package
+    (name "slurm-monitor")
+    (version "0.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/mattthias/slurm")
+         (commit (string-append "upstream/" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n6pgrcs8gwrcq5fch1q3yk3jipjwrf21s9a13fbjrl903g5zzv9"))))
+    (build-system cmake-build-system)
+    (arguments `(#:tests? #f)) ;; no tests
+    (inputs `(("ncurses" ,ncurses)))
+    (synopsis "Network load monitor")
+    (description
+     "Yet another network load monitor.  Slurm shows @samp{realtime} traffic
+statistics from any network device in any of three ASCII graph formats.")
+    (home-page "https://github.com/mattthias/slurm")
+    (license license:gpl2)))
+
 (define-public srt
   (package
     (name "srt")