diff mbox series

[bug#48554,wip-gnome,v5,2/2] gnu: Update gtkmm to 4.2.0, add gtkmm@3, and adjust gtkmm@2.

Message ID 20210902200954.30924-2-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48554,wip-gnome,v5,1/2] gnu: Add gtk. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Sept. 2, 2021, 8:09 p.m. UTC
* gnu/packages/gtk.scm (gtkmm)[version]: Update to 4.2.0.
[arguments](meson): New argument.
[native-inputs]: Add glib:bin.
[propagated-inputs]: Replace gtk+ with gtk.
[synopsis]: Modify.
[description]: Modify
(gtkmm-3): New variable.
(gtkmm-2)[arguments]: Strip certain inherited arguments.
---
 gnu/packages/gtk.scm | 48 +++++++++++++++++++++++++++++++-------------
 1 file changed, 34 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 97eda06d4b..e6bac6a230 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1747,7 +1747,7 @@  library.")
 (define-public gtkmm
   (package
     (name "gtkmm")
-    (version "3.24.4")
+    (version "4.2.0")
     (source
      (origin
        (method url-fetch)
@@ -1756,11 +1756,12 @@  library.")
                        (version-major+minor version)  "/"
                        name "-" version ".tar.xz"))
        (sha256
-        (base32 "0hv7pviln4cpjvpz7m7ga5krcsbibqzixdcn0dwzpz0cx71p3swv"))))
+        (base32 "12x9j82y37r4v0ngs22rzp4wmw7k2bbb9d3bymcczzz7y8w4q328"))))
     (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
-     `(#:configure-flags '("-Dbuild-documentation=true")
+     `(#:meson ,meson-0.55     ;project requires meson v0.54 or higher
+       #:configure-flags '("-Dbuild-documentation=true")
        #:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
@@ -1783,6 +1784,7 @@  library.")
     (native-inputs
      `(("dot" ,graphviz)
        ("doxygen" ,doxygen)
+       ("glib:bin" ,glib "bin")
        ("m4" ,m4)
        ("mm-common" ,mm-common)
        ("perl" ,perl)
@@ -1793,11 +1795,11 @@  library.")
      `(("atkmm" ,atkmm)
        ("cairomm" ,cairomm)
        ("glibmm" ,glibmm)
-       ("gtk+" ,gtk+)
+       ("gtk" ,gtk)
        ("pangomm" ,pangomm)))
-    (synopsis "C++ Interfaces for GTK+ and GNOME")
+    (synopsis "C++ Interfaces for GTK and GNOME")
     (description "GTKmm is the official C++ interface for the popular GUI
-library GTK+.  Highlights include typesafe callbacks, and a comprehensive set of
+library GTK.  Highlights include typesafe callbacks, and a comprehensive set of
 widgets that are easily extensible via inheritance.  You can create user
 interfaces either in code or with the Glade User Interface designer, using
 libglademm.  There's extensive documentation, including API reference and a
@@ -1810,6 +1812,30 @@  tutorial.")
       ;; Tools
       license:gpl2+))))
 
+(define-public gtkmm-3
+  (package
+    (inherit gtkmm)
+    (name "gtkmm")
+    (version "3.24.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version)  "/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0hv7pviln4cpjvpz7m7ga5krcsbibqzixdcn0dwzpz0cx71p3swv"))))
+    (arguments
+     (strip-keyword-arguments
+      '(#:meson) (package-arguments gtkmm)))
+    (propagated-inputs
+     `(("atkmm-2.28" ,atkmm-2.28)
+       ("cairomm-1.13" ,cairomm-1.13)
+       ("glibmm" ,glibmm)
+       ("gtk+" ,gtk+)
+       ("pangomm-2.42" ,pangomm-2.42)))))
+
 (define-public gtkmm-2
   (package
     (inherit gtkmm)
@@ -1826,14 +1852,8 @@  tutorial.")
         (base32 "0wkbzvsx4kgw16f6xjdc1dz7f77ldngdila4yi5lw2zrgcxsb006"))))
     (build-system gnu-build-system)
     (arguments
-     (substitute-keyword-arguments (package-arguments gtkmm)
-       ((#:modules modules %gnu-build-system-modules)
-        `((srfi srfi-1)
-          ,@modules))
-       ((#:configure-flags flags)
-        `(fold delete
-               ,flags
-               '("-Dbuild-documentation=true")))))
+     (strip-keyword-arguments
+      '(#:meson #:configure-flags) (package-arguments gtkmm)))
     (propagated-inputs
      `(("atkmm" ,atkmm-2.28)
        ("cairomm" ,cairomm-1.13)