diff mbox series

[bug#50342,core-updates-frozen] gnu: php: Remove watchpoint tests on powerpc64le.

Message ID 20210902172941.72058-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#50342,core-updates-frozen] gnu: php: Remove watchpoint tests on powerpc64le. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Sept. 2, 2021, 5:29 p.m. UTC
All watchpoint tests except watch_002.phpt fail.  There’s an upstream bug
report about this problem so in the meantime remove them since it doesn’t
impact actually running PHP programs.

* gnu/packages/php.scm (php)[arguments]<#:phases>{prepare-tests}: Remove
watchpoint tests on powerpc64le.
---
 gnu/packages/php.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Ludovic Courtès Sept. 6, 2021, 11:52 a.m. UTC | #1
Hi,

Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:

> All watchpoint tests except watch_002.phpt fail.  There’s an upstream bug
> report about this problem so in the meantime remove them since it doesn’t
> impact actually running PHP programs.
>
> * gnu/packages/php.scm (php)[arguments]<#:phases>{prepare-tests}: Remove
> watchpoint tests on powerpc64le.

Applied, thanks!

Ludo’.
Thiago Jung Bauermann Sept. 6, 2021, 1:37 p.m. UTC | #2
Hi Ludo,

Em segunda-feira, 6 de setembro de 2021, às 08:52:27 -03, Ludovic Courtès 
escreveu:
> Hi,
> 
> Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:
> > All watchpoint tests except watch_002.phpt fail.  There’s an upstream
> > bug report about this problem so in the meantime remove them since it
> > doesn’t impact actually running PHP programs.
> > 
> > * gnu/packages/php.scm (php)[arguments]<#:phases>{prepare-tests}:
> > Remove
> > watchpoint tests on powerpc64le.
> 
> Applied, thanks!

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 89fa978bd28a..7022eb6c9a2a 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -197,6 +197,20 @@ 
                                 "Zend/tests/concat_003.phpt")))
                    '())
 
+             ,@(if (target-ppc64le?)
+                   ;; Drop tests known to fail on powerpc64le.
+                   '((for-each delete-file
+                               (list
+                                ;; phpdbg watchpoints don't work.
+                                ;; Bug tracked upstream at:
+                                ;; https://bugs.php.net/bug.php?id=81408
+                                "sapi/phpdbg/tests/watch_001.phpt"
+                                "sapi/phpdbg/tests/watch_003.phpt"
+                                "sapi/phpdbg/tests/watch_004.phpt"
+                                "sapi/phpdbg/tests/watch_005.phpt"
+                                "sapi/phpdbg/tests/watch_006.phpt")))
+                   '())
+
              ;; Drop tests that are known to fail.
              (for-each delete-file
                        '("ext/posix/tests/posix_getgrgid.phpt"    ; Requires /etc/group.