diff mbox series

[bug#49533,v3] gnu: Add omins-lv2.

Message ID 20210902085647.6272-1-t_w_@freenet.de
State New
Headers show
Series [bug#49533,v3] gnu: Add omins-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms Sept. 2, 2021, 8:56 a.m. UTC
* gnu/packages/audio.scm (omins-lv2): New variable.
---
 gnu/packages/audio.scm | 33 ++++++++++++++++++++++++++++++++-
 1 file changed, 32 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 80cd521773..d135bfdf3d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5410,3 +5410,34 @@  device.  There is support for mono and/or stereo and 8 or 16 bit samples.")
      "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
 instrument plugins.")
     (license license:gpl3+)))
+
+(define-public omins-lv2
+  (let ((commit "058f341053067b69a84d4081107fda5058290ff9")
+	(revision "1"))
+    (package
+     (name "omins-lv2")
+     ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+     ;; version the author ever specified:
+     (version (git-version "0.0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri
+	(git-reference
+	 (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+	 (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+	(base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+     (build-system waf-build-system)
+     (arguments
+      `(#:tests? #f)) ; There are no tests.
+     (inputs
+      `(("lv2" ,lv2)))
+     (native-inputs
+      `(("pkg-config" ,pkg-config)))
+     (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+     (synopsis "LV2 audio plugins for modular synthesis")
+     (description
+      "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+     (license license:gpl2+))))