diff mbox series

[bug#50330] gnu: mandoc: Add $MANPATH to native-search-paths.

Message ID 20210901235853.882045-1-milkeymouse@meme.institute
State Accepted
Headers show
Series [bug#50330] gnu: mandoc: Add $MANPATH to native-search-paths. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Milkey Mouse Sept. 1, 2021, 11:58 p.m. UTC
* gnu/packages/man.scm (mandoc)[native-search-paths]: New field.
---
I use mandoc as a substitute for man-db, and when man-db isn't
installed, mandoc was finding no man pages as $MANPATH wasn't being
set. I don't think it causes any problems for MANPATH to be in the
native-search-paths of both mandoc and man-db, right?

 gnu/packages/man.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès Sept. 7, 2021, 2:06 p.m. UTC | #1
Hi,

Milkey Mouse <milkeymouse@meme.institute> skribis:

> * gnu/packages/man.scm (mandoc)[native-search-paths]: New field.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 50295b55f7..49e149128d 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -254,6 +254,10 @@  the traditional flat-text whatis databases.")
                                         "\n"))))))))
     (native-inputs `(("perl" ,perl)))             ;used to run tests
     (inputs `(("zlib" ,zlib)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "MANPATH")
+            (files '("share/man")))))
     (synopsis "Tools for BSD mdoc and man pages")
     (description
      "mandoc is a suite of tools compiling mdoc, the roff macro language of