diff mbox series

[bug#50325,v2] gnu: Add fatrace.

Message ID 20210901204335.17131-1-raphael.melotte@mind.be
State Accepted
Headers show
Series [bug#50325,v2] gnu: Add fatrace. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raphaël Mélotte Sept. 1, 2021, 8:43 p.m. UTC
* gnu/packages/monitoring.scm (fatrace): New variable.
---
Changes v1 -> v2 (all suggested by Xinglu Chen):
  - put modify-phases on its own line.
  - update the description.
  - fix the comment for the check phase.

 gnu/packages/monitoring.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Xinglu Chen Sept. 2, 2021, 8:02 p.m. UTC | #1
On Wed, Sep 01 2021, Raphaël Mélotte wrote:

> * gnu/packages/monitoring.scm (fatrace): New variable.
> ---
> Changes v1 -> v2 (all suggested by Xinglu Chen):
>   - put modify-phases on its own line.
>   - update the description.
>   - fix the comment for the check phase.

LGTM!  I don’t have commit access though.
Ludovic Courtès Sept. 3, 2021, 8:17 p.m. UTC | #2
Hi,

Raphaël Mélotte <raphael.melotte@mind.be> skribis:

> * gnu/packages/monitoring.scm (fatrace): New variable.

Applied.

Thank you, and thanks Xinglu for the review!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index d2aef0eaab..46dea5eeb8 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -650,3 +651,35 @@  LAN, if wanted, and clients can switch between multiple hosts on the network.
 Hostscope features a bridge to Influx DB.  So Grafana can be used to visualize
 the recorded data over time.")
     (license license:gpl3+)))
+
+(define-public fatrace
+  (package
+    (name "fatrace")
+    (version "0.16.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/martinpitt/fatrace")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bxz6v1z0icp716jnv3knjyqp8bv6xnkz8gqd8z3g2b6yxj5xff3"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         ;; tests need root to run as root,
+         ;; and there is no make target for them:
+         (delete 'check))
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))))
+    (synopsis "File access events monitor")
+    (description "This package provides a utility to report system wide file
+access events from all running processes.  Its main purpose is to find
+processes which keep waking up the disk unnecessarily and thus prevent some
+power saving.")
+    (home-page "https://github.com/martinpitt/fatrace")
+    (license license:gpl3+)))