diff mbox series

[bug#50213,1/6] gnu: python-werkzeug: Update to 2.0.1.

Message ID 20210901030958.16733-1-jgart@dismail.de
State New
Headers show
Series [bug#50213,1/6] gnu: python-werkzeug: Update to 2.0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Sept. 1, 2021, 3:09 a.m. UTC
* gnu/packages/python-web.scm (python-werkzeug): Update to 2.0.1.
[propagated-inputs]: Add python-pytest-xprocess and python-pytest-6.
[arguments]: Disable tests that require an internet connection.

Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name>
---
 gnu/packages/python-web.scm | 16 +++++++++++-----
 1 file changed, 11 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32b4aa4bf0..07db685e2a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4097,14 +4097,14 @@  List.  Forked from and using the same API as the publicsuffix package.")
 (define-public python-werkzeug
   (package
     (name "python-werkzeug")
-    (version "1.0.1")
+    (version "2.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Werkzeug" version))
        (sha256
         (base32
-         "0z74sa1xw5h20yin9faj0vvdbq713cgbj84klc72jr9nmpjv303c"))))
+         "0hlwawnn8c41f254qify5jnjj8xb97n294h09bqimzqhs0qdpq8x"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -4112,13 +4112,19 @@  List.  Forked from and using the same API as the publicsuffix package.")
          (delete 'check)
          (add-after 'install 'check
            (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; requires networking
+             (for-each delete-file
+               (list "tests/middleware/test_http_proxy.py"
+                     "tests/test_serving.py"
+                     "tests/test_debug.py"))
              (add-installed-pythonpath inputs outputs)
-             (invoke "python" "-m" "pytest"))))))
+             (invoke "pytest" "-vv"))))))
     (propagated-inputs
      `(("python-requests" ,python-requests)))
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("python-pytest-timeout" ,python-pytest-timeout)))
+     `(("python-pytest" ,python-pytest-6)
+       ("python-pytest-timeout" ,python-pytest-timeout)
+       ("python-pytest-xprocess" ,python-pytest-xprocess)))
     (home-page "https://palletsprojects.com/p/werkzeug/")
     (synopsis "Utilities for WSGI applications")
     (description "One of the most advanced WSGI utility modules.  It includes a