diff mbox series

[bug#50298] gnu: Remove harmonist-tk.

Message ID 20210831140054.32696-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#50298] gnu: Remove harmonist-tk. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 31, 2021, 2 p.m. UTC
harmonist-tk has been superseded by harmonist-sdl. Current harmonist-tk
package fails to build due to upgrade of harmonist to 0.4.1.

* gnu/packages/games.scm (harmonist-tk): Remove variable.
---
 gnu/packages/games.scm | 20 --------------------
 1 file changed, 20 deletions(-)

Comments

Julien Lepiller Sept. 1, 2021, 2:46 a.m. UTC | #1
Pushed as 1a657497acdead9afbeb24db6102f645d7e28ac9, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5e200f425..1a9cd36fee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9460,26 +9460,6 @@  the game avoids complex inventory management and character building, relying
 on items and player adaptability for character progression.")
     (license license:isc)))
 
-(define-public harmonist-tk
-  (package
-    (inherit harmonist)
-    (name "harmonist-tk")
-    (arguments
-      (append
-        (package-arguments harmonist)
-        `(#:phases
-          (modify-phases %standard-phases
-            (replace 'build
-              (lambda _
-                (invoke "go" "install" "-v" "-x" "--tags" "tk"
-                        "git.tuxfamily.org/harmonist/harmonist")))
-            (replace 'check
-              (lambda _
-                (invoke "go" "test" "--tags" "tk"
-                        "git.tuxfamily.org/harmonist/harmonist")))))))
-    (inputs
-     `(("go-github.com-nsf-gothic" ,go-github.com-nsf-gothic)))))
-
 (define-public drascula
   (package
     (name "drascula")