diff mbox series

[bug#50283,v1,1/2] gnu: Add libx86emu.

Message ID 20210830193525.2288-1-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#50283,v1,1/2] gnu: Add libx86emu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Aug. 30, 2021, 7:35 p.m. UTC
* gnu/packages/virtualization.scm (libx86emu): New variable.
---
 gnu/packages/virtualization.scm | 52 +++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

Comments

pelzflorian (Florian Pelz) Aug. 30, 2021, 11:13 p.m. UTC | #1
Hi Raghav,

On Mon, Aug 30, 2021 at 03:35:24PM -0400, Raghav Gururajan via Guix-patches via wrote:
> * gnu/packages/virtualization.scm (libx86emu): New variable.
> […]
> +    (license license:isc)))

This is the third time someone submits libx86emu. :D

https://issues.guix.gnu.org/49934

https://issues.guix.gnu.org/45744.

Your patch looks good (I am not very familiar with packaging habits
and have not tested though), but isn’t this license:x11-style?

Regards,
Florian
Raghav Gururajan Aug. 30, 2021, 11:27 p.m. UTC | #2
Hi Florian!

> This is the third time someone submits libx86emu. :D
> 
> https://issues.guix.gnu.org/49934
> 
> https://issues.guix.gnu.org/45744.

Yeah, I was informed in IRC after I sent this patch-set.

I have combined the patches into one and sent v2 to this thread.

> Your patch looks good (I am not very familiar with packaging habits
> and have not tested though), but isn’t this license:x11-style?

The wordings coincide with ISC and expat. Should I mention non-copyleft 
instead?

Regards,
RG.
pelzflorian (Florian Pelz) Aug. 31, 2021, 9:35 a.m. UTC | #3
Thank you for merging the others’ patches.

Could you change the grammar of the description as I wrote at
<https://issues.guix.gnu.org/49934#5>?

On Mon, Aug 30, 2021 at 07:27:33PM -0400, Raghav Gururajan wrote:
> > but isn’t this license:x11-style?
> The wordings coincide with ISC and expat. Should I mention non-copyleft
> instead?

The wording is the same as
<https://directory.fsf.org/wiki/License:Modified_X11> except for the
licensor’s name, so I thought it best be specified as x11-style.

Regards,
Florian
pelzflorian (Florian Pelz) Aug. 31, 2021, 9:41 a.m. UTC | #4
On Tue, Aug 31, 2021 at 11:35:44AM +0200, pelzflorian (Florian Pelz) wrote:
> Thank you for merging the others’ patches.
> 
> Could you change the grammar of the description as I wrote at
> <https://issues.guix.gnu.org/49934#5>?

Oh you did, sorry.  It looks good to me except I did not notice maybe
instead of

You can,
@enumerate
[…]
@item provides a hook yo run after each instruction

it should be

You can  <--- no comma
@enumerate
[…]
@item add a hook yo run after each instruction


Regards,
Florian
pelzflorian (Florian Pelz) Aug. 31, 2021, 9:48 a.m. UTC | #5
On Tue, Aug 31, 2021 at 11:41:36AM +0200, pelzflorian (Florian Pelz) wrote:
> @item add a hook yo run after each instruction

Oops I made a typo “to run” not “yo run”.  Funny typo of mine.  You
did not mistype.  Yo would be in the wrong language register.

Regards,
Florian
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index e952c009b5..6dd5127bc6 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -130,6 +130,58 @@ 
   #:use-module (srfi srfi-26)
   #:use-module (ice-9 match))
 
+(define-public libx86emu
+  (package
+    (name "libx86emu")
+    (version "3.1")
+    (home-page "https://github.com/wfeldt/libx86emu")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url home-page)
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "104xqc6nj9rpi7knl3dfqvasf087hlz2n5yndb1iycw35a6j509b"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (include (string-append out "/include"))
+                    (lib (string-append out "/lib")))
+               ;; Remove unnecessary variables and
+               ;; correct the values of version and prefix.
+               (substitute* (find-files "." "Makefile")
+                 (("GIT2LOG.*=.*$") "")
+                 (("GITDEPS.*=.*$") "")
+                 (("VERSION.*=.*$")
+                  (string-append "VERSION := "
+                                 ,version "\n"))
+                 (("BRANCH.*=.*$") "")
+                 (("PREFIX.*=.*$")
+                  (string-append "PREFIX := " out "\n"))
+                 (("MAJOR_VERSION.*=.*$")
+                  (string-append "MAJOR_VERSION := "
+                                 ,(version-major version) "\n"))
+                 (("LIBDIR.*=.*$")
+                  (string-append "LIBDIR = " lib "\n"))
+                 (("/usr/include") include)))))
+         (delete 'configure))))         ; no configure script
+    (native-inputs
+     `(("nasm" ,nasm)
+       ("perl" ,perl)))
+    (synopsis "ISA x86 emulation library")
+    (description "Libx86emu is a small library to emulate x86 instructions.  The
+focus here is not a complete emulation but to cover enough for typical
+firmware blobs.")
+    (license license:isc)))
+
 (define (qemu-patch commit file-name sha256-bv)
   "Return an origin for COMMIT."
   (origin