diff mbox series

[bug#50282,3/5] gnu: Remove python2-rfc6555.

Message ID 20210830191345.7831-3-pierre.langlois@gmx.com
State Accepted
Headers show
Series gnu: offlineimap: Replace with offlineimap3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois Aug. 30, 2021, 7:13 p.m. UTC
* gnu/packages/python-xyz.scm (python2-rfc6555): Remove variable.
(python-rfc6555)[properties]: Remove field.
---
 gnu/packages/python-xyz.scm | 8 --------
 1 file changed, 8 deletions(-)

--
2.33.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 577353e65d..c3aedeae18 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18334,16 +18334,8 @@  validation of URIs (see RFC 3986) and IRIs (see RFC 3987).")
        "Python implementation of the Happy Eyeballs Algorithm described in RFC
 6555.  Provided with a single file and dead-simple API to allow easy vendoring
 and integration into other projects.")
-      (properties `((python2-variant . ,(delay python2-rfc6555))))
       (license license:asl2.0))))

-(define-public python2-rfc6555
-  (let ((base (package-with-python2
-               (strip-python2-variant python-rfc6555))))
-    (package/inherit base
-      (propagated-inputs
-       `(("python2-selectors2" ,python2-selectors2))))))
-
 (define-public python-bagit
   (package
     (name "python-bagit")