diff mbox series

[bug#50276,2/4] gnu: Add go-github-com-anaseto-gruid-tcell.

Message ID 20210830164041.19770-2-jgart@dismail.de
State Accepted
Headers show
Series [bug#50275,1/4] gnu: Add go-github-com-gdamore-tcell-v2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 30, 2021, 4:40 p.m. UTC
From: Guix Together <jgart@dismail.de>

* gnu/packages/games.scm (go-github-com-anaseto-gruid-tcell): New variable.

Co-authored-by: Arun Isaac <arunisaac@systemreboot.net>
Co-authored-by: Brice Waegeneire <brice@waegenei.re>
Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
---
 gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Maxim Cournoyer Aug. 30, 2021, 7:35 p.m. UTC | #1
Hi,

This came out as patch 2, but depends on patch 3 :-).

jgart <jgart@dismail.de> writes:

> From: Guix Together <jgart@dismail.de>
>
> * gnu/packages/games.scm (go-github-com-anaseto-gruid-tcell): New variable.
>
> Co-authored-by: Arun Isaac <arunisaac@systemreboot.net>
> Co-authored-by: Brice Waegeneire <brice@waegenei.re>
> Co-authored-by: jgart <jgart@dismail.de>
> Co-authored-by: Julien Lepiller <julien@lepiller.eu>
> ---
>  gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 07a61f2c0b..262b85edc0 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -131,6 +131,7 @@
>    #:use-module (gnu packages gnu-doc)
>    #:use-module (gnu packages gnupg)
>    #:use-module (gnu packages gnuzilla)
> +  #:use-module (gnu packages golang)
>    #:use-module (gnu packages gperf)
>    #:use-module (gnu packages graphics)
>    #:use-module (gnu packages gsasl)
> @@ -9373,6 +9374,36 @@ and bring the war to your enemy.")
>                     license:expat license:fdl1.3+ license:public-domain
>                     license:zlib))))
>  
> +(define-public go-github-com-anaseto-gruid-tcell
> +  (package
> +    (name "go-github-com-anaseto-gruid-tcell")
> +    (version "0.1.1")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/anaseto/gruid-tcell")
> +               (commit (string-append "v" version))))
> +        (file-name (git-file-name name version))
> +        (sha256
> +          (base32
> +            "09ajr9mbldjfc44qprplbf8dr8yhlbn2nfnas2z62m9wmklc0qiv"))))
> +    (build-system go-build-system)
> +    (arguments
> +      '(#:import-path "github.com/anaseto/gruid-tcell"))
> +    (propagated-inputs
> +      `(("go-github-com-gdamore-tcell-v2"
> +         ,go-github-com-gdamore-tcell-v2)
> +        ("go-github-com-anaseto-gruid"
> +         ,go-github-com-anaseto-gruid)))
> +    (home-page
> +      "https://github.com/anaseto/gruid-tcell")
> +    (synopsis "Gruid driver using the tcell library")
> +    (description
> +"The gruid-tcell module provides a gruid driver for building terminal 
> +full-window applications.")
> +    (license license:isc)))
> +
>  (define-public harmonist
>    (package
>      (name "harmonist")

I fixed the indentation using Emacs and compressed the fields as bit,
like so:

1 file changed, 15 insertions(+), 19 deletions(-)
gnu/packages/games.scm | 34 +++++++++++++++-------------------

modified   gnu/packages/games.scm
@@ -9407,29 +9407,25 @@ application.")
     (name "go-github-com-anaseto-gruid-tcell")
     (version "0.1.1")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/anaseto/gruid-tcell")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-          (base32
-            "09ajr9mbldjfc44qprplbf8dr8yhlbn2nfnas2z62m9wmklc0qiv"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/anaseto/gruid-tcell")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "09ajr9mbldjfc44qprplbf8dr8yhlbn2nfnas2z62m9wmklc0qiv"))))
     (build-system go-build-system)
     (arguments
-      '(#:import-path "github.com/anaseto/gruid-tcell"))
+     '(#:import-path "github.com/anaseto/gruid-tcell"))
     (propagated-inputs
-      `(("go-github-com-gdamore-tcell-v2"
-         ,go-github-com-gdamore-tcell-v2)
-        ("go-github-com-anaseto-gruid"
-         ,go-github-com-anaseto-gruid)))
-    (home-page
-      "https://github.com/anaseto/gruid-tcell")
+     `(("go-github-com-gdamore-tcell-v2" ,go-github-com-gdamore-tcell-v2)
+       ("go-github-com-anaseto-gruid" ,go-github-com-anaseto-gruid)))
+    (home-page "https://github.com/anaseto/gruid-tcell")
     (synopsis "Gruid driver using the tcell library")
-    (description
-"The gruid-tcell module provides a gruid driver for building terminal 
-full-window applications.")
+    (description "The gruid-tcell module provides a Gruid driver for building
+terminal full-window applications.")
     (license license:isc)))

There also was an odd white space in the description; I capitalized
"Gruid".

Applied along go-github-com-anaseto-gruid, for which I did I applied a
similar treatment and pushed as efb756554939e4caa7bb2998b99ab6a95c43a4ec.

Thank you!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 07a61f2c0b..262b85edc0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -131,6 +131,7 @@ 
   #:use-module (gnu packages gnu-doc)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gnuzilla)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages gsasl)
@@ -9373,6 +9374,36 @@  and bring the war to your enemy.")
                    license:expat license:fdl1.3+ license:public-domain
                    license:zlib))))
 
+(define-public go-github-com-anaseto-gruid-tcell
+  (package
+    (name "go-github-com-anaseto-gruid-tcell")
+    (version "0.1.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/anaseto/gruid-tcell")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "09ajr9mbldjfc44qprplbf8dr8yhlbn2nfnas2z62m9wmklc0qiv"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/anaseto/gruid-tcell"))
+    (propagated-inputs
+      `(("go-github-com-gdamore-tcell-v2"
+         ,go-github-com-gdamore-tcell-v2)
+        ("go-github-com-anaseto-gruid"
+         ,go-github-com-anaseto-gruid)))
+    (home-page
+      "https://github.com/anaseto/gruid-tcell")
+    (synopsis "Gruid driver using the tcell library")
+    (description
+"The gruid-tcell module provides a gruid driver for building terminal 
+full-window applications.")
+    (license license:isc)))
+
 (define-public harmonist
   (package
     (name "harmonist")