diff mbox series

[bug#50251] gnu: kakoune: Update to v2021.08.28

Message ID 20210829113914.8545-1-calumirwin1@gmail.com
State Accepted
Headers show
Series [bug#50251] gnu: kakoune: Update to v2021.08.28 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Calum Irwin Aug. 29, 2021, 11:39 a.m. UTC
* gnu/packages/text-editors.scm (kakoune): Update to v2021.08.28
[native-inputs]: Use gcc-10.
[inputs]: Remove ncurses dependancy.
---
 gnu/packages/text-editors.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Lars-Dominik Braun Aug. 31, 2021, 12:11 p.m. UTC | #1
Hi,

looks good, added link to GitHub issue wrt GCC 7 support and pushed as
9af83d1cf98da8353a582c5cab62c2b01d7f8dc3.

Cheers,
Lars
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 2074442da5..44f23b4a24 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -163,7 +164,7 @@  based command language.")
 (define-public kakoune
   (package
     (name "kakoune")
-    (version "2020.09.01")
+    (version "2021.08.28")
     (source
      (origin
        (method url-fetch)
@@ -171,7 +172,7 @@  based command language.")
                            "releases/download/v" version "/"
                            "kakoune-" version ".tar.bz2"))
        (sha256
-        (base32 "0x81rxy7bqnhd9374g5ypy4w4nxmm0vnqw6b52bf62jxdg2qj6l6"))))
+        (base32 "1jvn4b9rma5jjvg3xz8nf224pbq3ry570j6qvc834wn5v3gxfvkg"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -194,11 +195,10 @@  based command language.")
          (add-before 'build 'chdir
            (lambda _ (chdir "src") #t)))))
     (native-inputs
-     `(("asciidoc" ,asciidoc)
+     `(("gcc", gcc-10)
+       ("asciidoc" ,asciidoc)
        ("pkg-config" ,pkg-config)
        ("ruby" ,ruby)))
-    (inputs
-     `(("ncurses" ,ncurses)))
     (synopsis "Vim-inspired code editor")
     (description
      "Kakoune is a code editor heavily inspired by Vim, as such most of its