diff mbox series

[bug#50213,15/19] gnu: Add python-dotenv.

Message ID 20210826151553.10127-15-jgart@dismail.de
State New
Headers show
Series [bug#50213,01/19] gnu: python-pytest-6: Update to 6.2.4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 26, 2021, 3:15 p.m. UTC
* gnu/packages/python-xyz.scm (python-dotenv): New variable.
---
 gnu/packages/python-xyz.scm | 43 +++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f379c54164..a63ee98dab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1931,6 +1931,49 @@  a library.")
     (description "DiskCache is a disk and file backed persistent cache.")
     (license license:asl2.0)))
 
+(define-public python-dotenv
+  (package
+    (name "python-dotenv")
+    (version "0.19.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "python-dotenv" version))
+        (sha256
+          (base32
+            "0wk1kfzbpqk9swvmpa9z3q170ffqql2id4b2dxrkrq58r4mbq8gm"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-sh" ,python-sh)
+       ("python-ipython" ,python-ipython)
+       ("python-pytest" ,python-pytest)
+       ("python-mock" ,python-mock)))
+    (propagated-inputs
+     `(("python-click" ,python-click)))
+    (home-page
+      "https://github.com/theskumar/python-dotenv")
+    (synopsis
+      "Read key-value pairs from a .env file and set them as environment variables")
+    (description
+"Python-dotenv reads key-value pairs from a .env file and can set them as environment
+variables.  It facilitates the development of applications following the 12 factors for
+building software-as-a-service apps as detailed by Adam Wiggins:
+@enumerate
+@item One codebase tracked in revision control, many deploys
+@item Explicitly declare and isolate dependencies
+@item Store config in the environment
+@item Treat backing services as attached resources
+@item Strictly separate build and run stages
+@item Execute the app as one or more stateless processes
+@item Export services via port binding
+@item Scale out via the process model
+@item Maximize robustness with fast startup and graceful shutdown
+@item Keep development, staging, and production as similar as possible
+@item Treat logs as event streams
+@item Run admin/management tasks as one-off processes
+@end enumerate")
+    (license license:bsd-4)))
+
 (define-public python-bitstruct
   (package
     (name "python-bitstruct")